MS Exchange IMAP: Random Crashes when accessing IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ]

VERIFIED FIXED

Status

MailNews Core
Backend
--
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Ralf Angeli, Assigned: jag (Peter Annema))

Tracking

({crash, imap-interop})

Trunk
x86
Linux
crash, imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
Mozilla is crashing while opening an IMAP mailbox (MS Exchange). The crash
occurs right after entering the mailbox password. Note: I am using SSL with this
mail account.
The crash occured first in builds from 2001-10-17 (builds before that date are
not crashing).
Talkback ID of the crash using build 2001102008 on Linux (SuSE 7.1, kernel
2.4.10) is: TB36969911G

Updated

17 years ago
Severity: normal → critical
Keywords: crash
CC: stephend@netscape.com, for talkback retrieval, please (TB36969911G)
Incident ID 36969911 
Stack Signature NS_ConvertUTF8toUCS2::Init() 964506f3  
Bug ID  
Trigger Time  2001-10-21 03:09:31  
Email Address   
URL visited   
User Comments  Crash occured while opening an IMAP mail account right after 
submitting password via SSL.  
Build ID 2001102006  
Product ID MozillaTrunk  
Platform ID LinuxIntel  
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)  
Stack Trace  
NS_ConvertUTF8toUCS2::Init() 
nsMimeConverter::DecodeMimeHeader() 
nsMsgDatabase::RowCellColumnToMime2DecodedString() 
nsMsgHdr::GetMime2DecodedSubject() 
nsMsgDBView::FetchSubject() 
nsMsgDBView::GetCellText() 
nsOutlinerBodyFrame::PaintText() 
nsOutlinerBodyFrame::PaintCell() 
nsOutlinerBodyFrame::PaintRow() 
nsOutlinerBodyFrame::Paint() 
PresShell::Paint() 
nsView::Paint() 
nsViewManager::RenderDisplayListElement() 
nsViewManager::RenderViews() 
nsViewManager::Refresh() 
nsViewManager::DispatchEvent() 
HandleEvent() 
nsWidget::DispatchEvent() 
nsWidget::DispatchWindowEvent() 
nsWindow::DoPaint() 
nsWindow::Update() 
nsWindow::UpdateIdle() 
libglib-1.2.so.0 + 0x11cdf (0x40365cdf) 
libglib-1.2.so.0 + 0x10be6 (0x40364be6) 
libglib-1.2.so.0 + 0x11213 (0x40365213) 
libglib-1.2.so.0 + 0x113dc (0x403653dc) 
libgtk-1.2.so.0 + 0x9204c (0x4028104c) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x1cbaf (0x404acbaf) 
No dupes found. Marking NEW.

Related to bug 105904? (that also has the string "NS_ConvertUTF8toUCS2::Init").
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Crash on opening IMAP mailbox → Crash on opening IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ]

Comment 4

17 years ago
I cannot reproduce this crash on 10-20-12-0.9.4 branch build for our internal MS 
Exchange 5.5 server. 
Are you using trunk build, can you reproduce this crash again on the latest 
build?
QA Contact: esther → huang

Comment 5

17 years ago
Is this crash also occuring on your MS Exchange server WITHOUT SSL?
I tested on our Messaging server SSL is working without crash.
Since we don't have MS Exchange SSL setting internally, do you have test 
accounts for me to test? If yes, can you send the server/account info to me? 
Thanks.
(Reporter)

Comment 6

17 years ago
The latest trunk build (2001102210) seems to work. I cannot see the crash
anymore either.

Comment 7

17 years ago
Great! Thanks for the updates. Marking as WFM based on reporter's comments.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
Verified. Please reopen this bug if you see the crash again, thanks,
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

17 years ago
Ooops, sorry, I got the crash again. :o(
First it was working fine, but then I deleted some mails and Mozilla crashed.
After that I could not open the mailbox anymore without crashing.
The talkback ID of the reproduced crash is TB37027942M.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

17 years ago
Is this crash also occuring on your MS Exchange server WITHOUT SSL?
Summary: Crash on opening IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ] → MS Exchange SSL: Crash on opening IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ]

Updated

17 years ago
Keywords: interop
Summary: MS Exchange SSL: Crash on opening IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ] → MS Exchange IMAP SSL: Crash on opening IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ]

Comment 11

17 years ago
I am still not getting the crash even after I deleted msgs from our Netscape 
Messaging IMAP SSL account.....
Summary: MS Exchange IMAP SSL: Crash on opening IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ] → MS Exchange IMAP SSL: Crash on opening IMAP mailbox after deleting msgs [@ NS_ConvertUTF8toUCS2::Init() ]
(Reporter)

Comment 12

17 years ago
Yes, I got the same crash without SSL. The crash occurs either while opening the
mailbox or randomly when you move around in your mailbox or delete some mails.
I am using a trunk build, maybe the problem does not exist in branch builds.

Maybe Alex is right and this is related to bug 105904, even if the reporter
there is just reporting a hang and not a crash.

Comment 13

17 years ago
Thanks for checking.
Updating the summary a little bit and adding bug 105904 for this bug dependance 
based on reporter's comments.
Depends on: 105904
Summary: MS Exchange IMAP SSL: Crash on opening IMAP mailbox after deleting msgs [@ NS_ConvertUTF8toUCS2::Init() ] → MS Exchange IMAP: Random Crashes when accessing IMAP mailbox [@ NS_ConvertUTF8toUCS2::Init() ]

Comment 14

17 years ago
cc'ing jag.  This looks similar to 105904.  Is this also your bug, jag?
(Assignee)

Comment 15

17 years ago
Yeah, that's mine.

I have two different approaches to fixing this, I need to go over them with
dbaron and scc.

Comment 16

17 years ago
reassigning to jag based on his last comments.
Assignee: mscott → jaggernaut
Status: REOPENED → NEW
Keywords: mailtrack
(Assignee)

Comment 17

17 years ago
This should be fixed. Please verify!
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

17 years ago
I am using Mail/News (build 2001102521) for nearly a day now and haven't had a
crash. So the fix seems to be bulletproof. :o) Thanks for that.
I don't know if I, as a reporter, am entitled to mark the bug as verified, so
I'm leaving the status untouched.

Comment 19

17 years ago
Verified no crash for accessing MS Exchange mail account now.
Windows and Linux Build 11-15-06-trunk build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ NS_ConvertUTF8toUCS2::Init() ]
You need to log in before you can comment on or make changes to this bug.