error message when creating test cases in Testopia 2.5

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: raronson, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Steps to reproduce:

We are running Testopia 2.5 with Bugzilla 4.4 in a virtual development server while learning and
developing our test case management strategy.

When I try to create a new test case, I am getting the following error.


Actual results:

===================================================
There was an error loading the data: <h1>Software error:</h1>
<pre>Can't call method &quot;login&quot; on an undefined value at C:/Program
Files/bugzilla/tr_quicksearch.cgi line 463.
</pre>
<p>
For help, please send mail to the webmaster (<a
href="mailto:it <at> rgb.corp">it <at> rgb.corp</a<mailto:it <at> rgb.corp%3c/a>>), giving this error message
and the time and date of the error.

</p>
===================================================


Expected results:

no error message...
This error was the result of the resolution of bug 445861, It has since been fixed in bug 980234, so feel free to use the patch provided in this bug, which has been tested successfully. The next release of Testopia will include this patch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → 2.6
(Reporter)

Comment 2

4 years ago
thanks for the help...can you provide instructiona to apply the patch?

cheers,
rich
As the patch is written with the git repository in mind, I suggest that you handle this manually. The patch information mentions the file that needs to be changed (tr_quicksearch.cgi, in this case), and what lines are added and removed (denoted by + and -, respectively). Use the line number provided (450, in this case) as a guideline (as well as lines not marked with a + or - in the patch).

There are also other methods (such as is explained here: http://stackoverflow.com/questions/3418277/how-to-apply-git-diff-patch-without-git-installed), but I have not personally tested this method.
You need to log in before you can comment on or make changes to this bug.