`Resolving host xyz.foo.bar...' should be `Looking up xyz.foo.bar...'

RESOLVED FIXED in Future

Status

()

Core
Networking
--
trivial
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Matthew Paul Thomas, Unassigned)

Tracking

({polish})

Trunk
Future
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2001101904, Mac OS 9.1

To reproduce:
1.  Go to a Web site on a server you haven't been to in a while (such that it's
    not in your DNS cache).
2.  Look at the status bar.

What you see:
*   `Resolving host nameOfServer...'

What you should see:
*   `Looking for nameOfServer...'

Q & A from bug 97028 (from which this bug is spun off):

Why not `Resolving host'?
    Because only a miniscule proportion of the population knows what a `host'
    is, let alone what it means to `resolve' it. `Looking for' is much more
    understandable, while still being correct.
Why not `Looking up' instead of `Looking for'?
    For the same reason. Most people are unaware that IP numbers are stored in
    an index, so `Looking for' makes more sense while still being correct.
Eventually, we need to design several UI behaviors, tailored to various users.
    Uh, this is a Web browser's status bar, it's not a wedding dress. Even in
    the highly unlikely event that we wanted the status text to be themable
    independently from the rest of the browser, that's waaaaay outside the
    scope of this bug.
I know, let's redesign the status bar text for every networking state before we 
change anything!
    Uh, no. Firstly, it would take a long time to spec, and even longer to
    implement. Secondly, no matter what the status text for the other states
    ends up being, `Looking for {serverName}...' will be the status text for
    the initial domain resolution. (I will do a spec, once someone sends me a
    list of all those networking states.) And thirdly, `Resolving host' is the
    most obvious status text currently (especially on a high-speed connection),
    so its disturbing obfuscation should be fixed promptly.
Won't changing this string confuse Networking QA people?
    I think they're smart enough not to be confused by this, really. And
    anyway, Networking QA people make up a positively microscopic proportion of
    users of Mozilla distributions.
(Reporter)

Updated

17 years ago
Severity: normal → trivial
Keywords: polish
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: `Resolving host xyz.foo.bar...' should be `Looking for xyz.foo.bar ...' → `Resolving host xyz.foo.bar...' should be `Looking for xyz.foo.bar...'

Comment 1

17 years ago
I find this suggestion upsetting. It should never never never be "Looking
for..." - that looks amateurish at best, and is confusing: "Looking for"
indicates a physical action. To "look something up", on the other hand, is the
established abstract used, whether speaking about a catalogue, a dictionary, any
other book - or networking lookups. This is old and well established
linguistics, probably with roots back to the 15th century.

Secondly: I have never seen any networking application that is "Looking for".

IMO a huge mistake to introduce a "Looking for" term in Mozilla.
What's next? A paperclip with a pair of eyes?

Comment 2

17 years ago
It looks like another bug that could be fixed in five minutes is going to get
drowned in wording discussion...

FWIW, I think 'Looking for www.example.com...' is fine.

Comment 3

17 years ago
Mozilla builds are not for general usage, they are for testing. Obviously the
hardcore networking QA people would understand the proposed change, we put up
with seriously bad status messages in Communicator 4 and IE for years. That is
not the actual audience that benefits from using the current status strings.

The current string set gives clear but simple descriptions of the actual
networking state of the connection. This is very useful information when dealing
with networking problem reports, and this was the general design goal of the
engineer that made it work this way. 

The underlying reason I think we should leave things be is that I WANT
non-networking testers to learn a little networking, just enough to file good
bugs. These status messages go a long way to that. I don't think this is too
much to ask.

re: "looking" I've made lots of comments in the UI bug (which I can't find),
about why thats a generally good idea that needs more work. I'll keep this as
short as possible by not repeating everything in this bug as well.

re: fast connections - i looks like something changed that makes resolving stick
around too long again. I'll file a new bug on that.

Comment 4

17 years ago
> Mozilla builds are not for general usage, they are for testing. Obviously the
> hardcore networking QA people would understand the proposed change, we put up
> with seriously bad status messages in Communicator 4 and IE for years. That is
> not the actual audience that benefits from using the current status strings.

Yes, but Netscape is made for general usage and Netscape so far haven't changed
the Mozilla status bar messages.

Personally, I don't care if it stays 'Resolving host www.example.com...' or
becomes 'Looking for www.example.com...'. They both make sense to me.

Comment 5

17 years ago
I would prefer "looking up xyz.foo.bar" to "looking for xyz.foo.bar".  I think 
advanced users would be able to figure out that "looking up" means "resolving 
host through DNS" more easily.  "Looking for" conjures up images of a browser 
stumbling blindly around the Internet, trying to find a server.  

Also, as rkaa said, "looking for" sounds like a physical action.  Connecting to 
the server given its IP address is more physical, and better described 
by "looking for", than resolving a hostname is.

By the way, the phrase "looking up" has has precedent for use in connection 
with DNS:

*** Connecting to irc.mozilla.org (6667)
-irc.mozilla.org- *** Looking up your hostname...
-irc.mozilla.org- *** Found your hostname, cached

Comment 6

17 years ago
As a test of how the suggested usage in this bug would work:
Replace "looking up" with "looking for" in the last line of the
quote below:

"To join the list and/or follow the responses, see the gopher for CIOS
which manages "ethno".  Either send the gopher command
"gopher cios.llc.rpi.edu" and look under the "hotlines" section for
"ethno" or do so by looking up the WWW URL: gopher://cios.llc.rpi.edu:70/ "

If "looking for" is used instead, the reader is given the erronous
impression that the last mentioned URL is something they
should look FOR under the "ethno" section mentioned earlyer in the text.

This happens because "looking FOR" first and formost indicates
an action by the individual; again using ones eyesight or "mental vision".

The replacement makes the text clearly misleading, and thus represent
an imprecise usage of language.

Comment 7

17 years ago
Just to put my two cents in...

"Resolving" is technically correct but somewhat beyond the scope of my mother's
understanding of that word.  (She resolves problems, not DNS entries)

"Looking for" is very much wrong from an english standpoint.  Name resolution
(DNS lookup) is not a search for the "www.domain.dom" machine but a look up of
the address of that machine from the directory.  It is not until you actually
know the stated address that you are actually "looking for" the machine (sending
a packet to that address)  And, in that case, you are not actually looking for
the machine, you are just trying to contact the machine.

"Looking up" is reasonably accurate (and very much what technical people call it
too - even nslookup is, well, by name a lookup)  Plus, that is what is happening
at that time - the name is being looked up to find the number (IP address) that
needs to be used to contact it.

As such, I would say the string should not be "Looking for" for the fact that it
is incorrect.

My personal preference would be for "Looking up" since "mom would understand" it
more so than "Resolving."

Comment 8

17 years ago
Most people in this bug seem concerned about status messages for Netscape 6
and/or consumer users, so I've marked this as nsonly. 

We've had the mozilla discussion in a previous UI bug, and it went nowhere, so
the status quo held. 

Currently, my understanding is that Netscape 6 has not added any features here,
so I think it is possible to discuss a set of strings and see if they will take it.
Keywords: nsonly

Comment 9

17 years ago
"Looking for ..." is technically incorrect and (from a technical standpoint)
misleading. If a ISP support bod was to hear a user say his web browser was
frozen whilst "Looking for cnn.com," the support bod would probably not think of
DNS, but a routing problem to cnn.com. I echo what Michael Sinz has said.

Also, "Looking up" is what people do when they need someone's address or
telephone number," thus it's not uncommon terminology. I would support this
change in Mozilla. If, however, you feel that Mozilla should be "Resolving host
...," please take this bug to bugscape and mark this WONTFIX.

Comment 10

17 years ago
There is a recent posting in the newsgroups complaining that mozilla is taking 
so much time for "resolving a hostname" compared to other browsers.
Especially annoying for power-users. If this isn't that difficult to fix, I'd 
suggest to approach quite soon.
Keywords: mozilla0.9.7

Updated

17 years ago
Target Milestone: --- → Future
Keywords: mozilla0.9.7
(Reporter)

Comment 11

16 years ago
Removing nsonly, since this bug exists for all Mozilla distributions.
Keywords: nsonly

Comment 12

16 years ago
moving neeti's futured bugs for triaging.
Assignee: neeti → new-network-bugs

Comment 13

14 years ago
"Looking up hostname.domain ..." is also the traditional Netscape 4.x status
message. 

Comment 14

14 years ago
Created attachment 147968 [details] [diff] [review]
Should fix the status bar message to "Looking up..."

Only problem now is, does anyone have ANY idea who to assign a review for this
to?

Comment 15

14 years ago
Comment on attachment 147968 [details] [diff] [review]
Should fix the status bar message to "Looking up..."

I realize the priority on this bug is not too high, but the fix is extremely
simple, so I thought I'd go ahead.
Attachment #147968 - Flags: review?(bzbarsky)
Comment on attachment 147968 [details] [diff] [review]
Should fix the status bar message to "Looking up..."

This needs review from Darin, I'd say.
Attachment #147968 - Flags: review?(bzbarsky) → review?(darin)

Comment 17

14 years ago
Any status update?

Comment 18

14 years ago
Comment on attachment 147968 [details] [diff] [review]
Should fix the status bar message to "Looking up..."

I don't think most people think beyond "oh, that's the start message, and then
there's the transferring, and then it's done". I'd say "looking up" is the best
way to ``translate'' "resolving". sr=jag, but get r= from darin since this is
his module.
Attachment #147968 - Flags: superreview+

Updated

14 years ago
Attachment #147968 - Flags: review?(darin) → review+

Comment 19

14 years ago
To anyone who's reading... I've sent out several requests to jag for checking in
this bug, but have received no response. I do not have checkin ability, so if
anyone viewing this does, please check this in for me. It would be MUCH appreciated.

Comment 20

14 years ago
Patch checked in. Marking bug fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 21

14 years ago
Tweaking summary to what was checked in ("Looking up", not "Looking for").
Summary: `Resolving host xyz.foo.bar...' should be `Looking for xyz.foo.bar...' → `Resolving host xyz.foo.bar...' should be `Looking up xyz.foo.bar...'
You need to log in before you can comment on or make changes to this bug.