Internet keywords: google has problems w/ "C++"

VERIFIED WORKSFORME

Status

SeaMonkey
Location Bar
P4
normal
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: John Levon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010928
BuildID:    2001092806

If I keyword for "stroustrup C++" (having set keywords to google
in prefs), it mangles the ++ part of C++

Reproducible: Always
Steps to Reproduce:
1. enable internet keywords
2. enter stroustrup C++ and press return


Actual Results:  search terms are "stroustrup C"

Expected Results:  search terms are "stroustrup C++"

Comment 1

17 years ago
-> samir
Assignee: blakeross → sgehani
Component: URL Bar → Search

Updated

17 years ago
Priority: -- → P4
Target Milestone: --- → mozilla0.9.7

Comment 2

17 years ago
Marking nEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Moving to mozilla0.9.8.
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 4

17 years ago
Moving to milestone after mozilla0.9.9 (mozilla1.0 for now).
Keywords: nsbeta1+
Target Milestone: mozilla0.9.8 → mozilla1.0

Comment 5

17 years ago
Search triage team: -> Future
Target Milestone: mozilla1.0 → Future

Comment 6

17 years ago
Mass move of nsbeta1+ bugs that didn't have a valid MachV milestone to mozilla1.0.
Target Milestone: Future → mozilla1.0

Comment 7

17 years ago
The nsbeta1+ was legacy cruft from way back when I was triaging and the only way
I was allowed to leave things in mozilla1.0 was by nsbeta1+'ing the bug.  Moving
back to Future.

Keywords: nsbeta1+
Target Milestone: mozilla1.0 → Future

Comment 8

17 years ago
+makingtest

Could be fixed with bug 127872.

Comment 9

15 years ago
I checked the older config (keyword.netscape.com), and that site displays the
search request properly.

I think our software works correctly, but since google is the new default, we
should track this.
Assignee: sgehani → location-bar
Component: Search → Location Bar
OS: Linux → All
QA Contact: claudius → benc
Hardware: PC → All
Summary: Internet keywords mangles some keywords → Internet keywords: google has problems w/ "C++"

Comment 10

14 years ago
A (probably)  related a bug is that characters like å (for words like skåne) are
also messed up when using the internet keywords (appears as a ? instead of å). 
The character is passed to google as %E5 from internet keywords but Google is
expecting %C3%A5 for å.  Similarly, mozilla passes + for + into google for its
searches, but Google seems to be expecting %2B instead.
WFM in minefield 2007040504.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 12

11 years ago
V/wfm: seamonkey 1.1.2/macosx 10.4.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.