Closed Bug 1059108 Opened 7 years ago Closed 7 years ago

Intermittent calls_handler_test.js,handled_call_test.js | Timed out after 120 seconds

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 fixed)

RESOLVED FIXED
2.1 S3 (29aug)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- fixed

People

(Reporter: cbook, Assigned: etienne)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

b2g_ubuntu64_vm mozilla-inbound opt test gaia-unit on 2014-08-26 23:28:01 PDT for push 8328bc2054d1

slave: tst-linux64-spot-607



TEST-UNEXPECTED-TIMEOUT | callscreen/test/unit/handled_call_test.js | Timed out after 120 seconds

https://tbpl.mozilla.org/php/getParsedLog.php?id=46835909&tree=Mozilla-Inbound
padenot: could this also be caused by the change for Bug 848954, seems it started there
Flags: needinfo?(paul)
Flags: needinfo?(paul)
Attached file Gaia PR
Clearly our bad. We have a unit test where we were mocking only part of the WebAudio API and bad stuff happened.

This should be much better.
Assignee: nobody → etienne
Attachment #8479894 - Flags: review?(anthony)
https://tbpl.mozilla.org/php/getParsedLog.php?id=46861867&tree=Mozilla-Inbound
Summary: Intermittent handled_call_test.js | Timed out after 120 seconds → Intermittent calls_handler_test.js,handled_call_test.js | Timed out after 120 seconds
Comment on attachment 8479894 [details] [review]
Gaia PR

Stealing.
Attachment #8479894 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/5c517820066eb1e35395372f6e25c8707e3a0596

needinfo? nigelb or Tomcat to get this merged from b2g-inbound to m-c ASAP. Gu is near perma-fail on trunk right now.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(nigelbabu)
Flags: needinfo?(cbook)
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
Here's another patch for the handled_call_test intermittent
Attachment #8480463 - Flags: review?(etienne)
Component: Gaia → Gaia::Dialer
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #28)
> https://github.com/mozilla-b2g/gaia/commit/
> 5c517820066eb1e35395372f6e25c8707e3a0596
> 
> needinfo? nigelb or Tomcat to get this merged from b2g-inbound to m-c ASAP.
> Gu is near perma-fail on trunk right now.

included in https://tbpl.mozilla.org/?rev=70c1c94cfaec
Flags: needinfo?(cbook)
Reopening for the second patch that needs to land still.
Status: RESOLVED → REOPENED
Flags: needinfo?(nigelbabu)
Resolution: FIXED → ---
There is a new failing test with this patch: https://tbpl.mozilla.org/?rev=df0e81d8cae86ba933f29aa6d6d71daac22451ad&tree=Gaia-Try

So I've updated my patch with audio_competing_helper_test.js changes. New try https://tbpl.mozilla.org/?rev=31673d58db2163499854d64cee9060bad7fe2357&tree=Gaia-Try
Comment on attachment 8480463 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23414

Green try \o/

Putting back in review since Étienne reviewed before my changes.
Attachment #8480463 - Flags: review+ → review?(etienne)
Comment on attachment 8480463 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23414

r=me with the comment on github addressed. Let's discuss it IRL if it's unclear.
Attachment #8480463 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/commit/46dfe07619244b94774d935e5f2b6fc421876c79
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.