Closed Bug 1059190 Opened 6 years ago Closed 5 years ago

Perform unboxing in FilterTypeSetPolicy::adjustInputs.

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1073861

People

(Reporter: eternalsushant, Unassigned)

References

Details

Perform unboxing to get better type information in [1] whenever possible.
See comments for more information.



-------
[1] http://dxr.mozilla.org/mozilla-central/source/js/src/jit/TypePolicy.cpp#844
Depends on: 1034184
I had to implement this eagerly, since there are bugs due to this not implemented.
I added this in bug 1073861
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1073861
You need to log in before you can comment on or make changes to this bug.