IMAP Mark as Deleted UI: Should change File Menu to "Compact This Folder"

VERIFIED DUPLICATE of bug 94251

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 94251
16 years ago
13 years ago

People

(Reporter: Karen Huang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Should change File Menu to "Compact This Folder" for IMAP Mark as deleted mode

Refer to bug 64751:
Our client had Compact (All) Folders feature for POP, Local and IMAP "Move to 
Trash" mode and "Delete Immediately" mode.
Our client should change File Menu to "Compact This Folder" for IMAP Mark as 
Deleted mode.

1) Login to a mail account with IMAP Mark as Deleted mode.
2) Select File Menu
3) Actual Results: Our client still displays "Compact Folders" for IMAP Mark as 
deleted mode

Expected Results: Since in IMAP Mark as Deleted mode, the functionality is 
Compact "This" Folder....so on UI should change File Menu to "Compact This 
Folder"
(Reporter)

Updated

16 years ago
QA Contact: esther → huang

Comment 1

16 years ago
The name of the menu item should not be "Compact This Folder" or "Compact
Folders."  It should be "Purge Deleted Messages" or "Purge Messages Marked for
Deletion."  

The meaning of the term "Compact" is far from obvious.  Is it making the folder
smaller on disk?  Is it performing janitorial services on the server?  Plus,
it's plural ("folders"), so I'm not sure if it's going to do things to other
folders (I assume that as implemented, it actually lies and compacts (purges)
just the current folder).

OTOH, If I've just hit "delete" and I'm looking for the menu option that will
*really* delete, I want to see an action term with the word "Deleted" in it, or
at least "Marked for Deletion".  

There is also an option "Empty Trash" that is distracting; in the absence of a
clear "Purge Deleted" function, users (e.g. me) will repeatedly attempt to empty
trash, since that's semantically close to what we really want to do.

In addition, the IMAP standard calls the action "Purge," and MS Outlook calls
the action "Purge Deleted Messages".  Bringing Mozilla in line with the rest of
the universe is not always a bad idea.



Comment 2

16 years ago
Isn't this a dupe of bug 94251 ("Compact Folders" should really say "Compact
Folder")?
(Reporter)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 94251 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.