Closed Bug 1059317 Opened 10 years ago Closed 10 years ago

Move talos stats to a separate panel

Categories

(Tree Management :: Treeherder, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: mdoglio)

References

Details

(Keywords: regression)

Attachments

(2 files)

In order to sheriff talos results, we need to have a quick way to click on a talos job and see the reported talos numbers.  Right now this needs to be the numbers reported to graph server which show up in the logs as:

18:55:12     INFO -  RETURN: <a href='http://graphs.mozilla.org/graph.html#tests=[[255,94,33]]'>tp5o_paint: 335.09</a>
18:55:12     INFO -  RETURN: <a href='http://graphs.mozilla.org/graph.html#tests=[[261,94,33]]'>tp5o_main_rss_paint: 187.5MB</a>
18:55:12     INFO -  RETURN: <a href='http://graphs.mozilla.org/graph.html#tests=[[257,94,33]]'>tp5o_pbytes_paint: 478.6MB</a>
18:55:12     INFO -  RETURN: <a href='http://graphs.mozilla.org/graph.html#tests=[[265,94,33]]'>tp5o_xres_paint: 9.6MB</a>
Summary: Tree herder UI shows no talos data → Treeherder UI shows no talos stats
I don't believe sheriffs need these links; if not, let's move from treeherder-blockers to treeherder-need.
Flags: needinfo?(emorley)
Correct
Flags: needinfo?(emorley)
hmm, have always viewed managing talos data a sheriff job- in order to manage talos regressions we rely 100% on tbpl, if we are going to manage talos regressions (just like unittest regressions) on tree herder we need to get serious about supporting the needs.

A concern I have is that we transition to treeherder for sheriffing but don't support sheriffing talos data we will either not maintain tbpl if problems arise, put a lower priority on treeherder talos sheriff needs, or some combination of both.
We still intend to fix this, and at a high priority (thus the treeherder-need blocker).  But it doesn't block the sheriff transition per se, since sheriffs don't use these links.  "Starring" in Treeherder will be backwards compatible with TBPL, so other users can continue to use TBPL as usual for some period of time (TBD).

We won't deprecate TBPL until this and other treeherder-need bugs are fixed (at a minimum).
See Also: → 1086663
is there anyway we can fix this one faster?  I still use tbpl 90% of the time because I need to view talos results.  I would really like to spend more time on treeherder to find the regressions and other nits for a top notch user experience.
:jmaher are you talking about the TalosResult numbers in the bottom panel?
Attached image graphserver.jpg
Is this the info you want to see on talos tests?
Flags: needinfo?(jmaher)
Yes that is the data I am referring to.  I have been helping folks sort out try server runs and this data is never there, so I always have to switch to tbpl.

On a productivity side, can we get that data higher in the view?  Assuming that data is there (which I haven't seen it on my try runs or on integration trees), I would like to just click on a job in the UI and see the results, not have to:
* click the job
* move the mouse down to the preview pane
* drag the scroll arrow down
* move the mouse because it is sometimes highlighting a link

My normal workflow [in tbpl] is to click a series of jobs and quickly view the results in the preview pane, the only mouse moves are to go from one job to the next.
Flags: needinfo?(jmaher)
Keywords: regression
hey, this bug is awesome and fun to fix if we put the talos results in a panel!  We talked about this in person in Portland.
Assignee: nobody → mdoglio
Summary: Treeherder UI shows no talos stats → Move talos stats to a separate panel
Attachment #8532050 - Flags: review?(cdawson)
:jmaher it was fun indeed :-)
Attachment #8532050 - Flags: review?(cdawson) → review+
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 1114722
hmm, this doesn't work for the e10s stuff, but it does work for everything else.  One example is:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=0532f2509f3f&filter-searchStr=talos%20linux

I click on the t-e10s job and it says the results are in the talos panel, but there is no talos panel
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bitten by hardcoded names:
https://github.com/mozilla/treeherder-ui/blob/master/webapp/app/plugins/controller.js#L90

The quick fix is to check for substring of talos, the longer term and preferred fix would be to change the schema so we can actually use the job category of "talos" here:
https://github.com/mozilla/treeherder-service/blob/5f0c9f7e055f4d5f895d713b303cf4ed419ee1d0/treeherder/etl/buildbot.py#L327
I find myself going back to tbpl as there is no way to access the e10s talos results.
Depends on: 1122680
Moved the following to bug 1122680, I'll take it.
s/following/followup/
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: