If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Inline image scaling introduces ugly aliasing

RESOLVED DUPLICATE of bug 98971

Status

Core Graveyard
GFX
RESOLVED DUPLICATE of bug 98971
16 years ago
9 years ago

People

(Reporter: Damian Yerrick, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.5+) Gecko/20011018
BuildID:    2001101803

As imaging technologies move from pixel sizing to physical (cm, pt,
etc.) sizing, web browsers will need to resample images to the user's
display resolution.  We can no longer rely on all inline images being
created at 96 dpi, stored at 96 dpi, sent over the wire at 96 dpi, and
displayed at 96 dpi.  We can't rely on Mozilla's current "nearest
neighbor" scaling algorithm that introduces horrible aliasing artifacts
because the ugly appearance of scaled images will discourage web site
designers from using resolution-independent markup and stylesheets.


Reproducible: Always
Steps to Reproduce:
1. Download and unzip the forthcoming attached test case.
2. From Mozilla, open aliasing.html
3. Scroll down to the "Actual" images.

Actual Results:  In both quirks and standard mode, scaled images have
ugly aliasing due to nearest-neighbor resampling.  (This also happens
in MS Internet Explorer 4.0, 5.0, 5.5, and 6.0 for Win32.)

Expected Results:  Scaled images have little aliasing.

To reduce aliasing by 6 dB/octave, use bilinear interpolation instead
of nearest neighbor resampling. If this poses a performance problem,
make it a preference.

Bug 90813 covers the same problem with respect to text rather than
inline images.
(Reporter)

Comment 1

16 years ago
Created attachment 54433 [details]
Test case demonstrating the ugliness of nearest neighbor
Duplicate of "Bilinear scaling need for line art and scalable web pages"  (which
has an implementation attached btw; it just needs to be integrated into Mozilla.

*** This bug has been marked as a duplicate of 98971 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.