You need to clobber only the OS X opt build when you hit "package-manifest:439: File missing (whatever jarred file someone just removed)" ("make[2]: *** [postflight_all] Error 2"/"make: *** [automation/package] Error 2")

RESOLVED WORKSFORME

Status

Firefox Build System
General
RESOLVED WORKSFORME
4 years ago
2 months ago

People

(Reporter: RyanVM, Unassigned)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
x86_64
Mac OS X
intermittent-failure
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Been seeing these for a couple of days now. Some sort of race?

https://tbpl.mozilla.org/php/getParsedLog.php?id=46875046&tree=Fx-Team

OS X 10.7 fx-team build on 2014-08-27 11:12:50 PDT for push 10346f72cdcb
slave: bld-lion-r5-080

mkdir -p /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/dist/universal/
rm -f /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/x86_64/dist/universal
ln -s /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/dist/universal /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/x86_64/dist/universal
make -C /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/browser/installer \
	   PKG_SKIP_STRIP=1 stage-package
OMNIJAR_NAME=omni.ja \
	/builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/_virtualenv/bin/python /builds/slave/fx-team-osx64-0000000000000000/build/toolkit/mozapps/installer/packager.py -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -DMOZ_APP_NAME=firefox -DPREF_DIR=defaults/preferences -DJAREXT= -DMOZ_CHILD_PROCESS_NAME=plugin-container -DMOZ_SHARED_MOZGLUE=1 -DNECKO_WIFI -DDLL_PREFIX=lib -DDLL_SUFFIX=.dylib -DBIN_SUFFIX= -DMOZ_FOLD_LIBS=1 -DAPPNAME=FirefoxNightly.app -DBINPATH=/FirefoxNightly.app/Contents/MacOS -DMOZ_ICU_VERSION=52 -DMOZ_ICU_DBG_SUFFIX= -DCLANG_CXX \
		--format omni \
		--removals /builds/slave/fx-team-osx64-0000000000000000/build/browser/installer/removed-files.in \
		 \
		 \
		 \
		 \
		--optimizejars \
		--unify /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/../x86_64/dist \
		package-manifest ../../dist ../../dist/universal/firefox \
		
Error: /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/browser/installer/package-manifest:439: File missing in ../../dist: FirefoxNightly.app/Contents/MacOS/browser/chrome/browser/skin/classic/browser/Privacy-48.png
Error: /builds/slave/fx-team-osx64-0000000000000000/build/obj-firefox/i386/browser/installer/package-manifest:439: File missing in ../../dist: FirefoxNightly.app/Contents/MacOS/browser/chrome/browser/skin/classic/browser/aboutPrivateBrowsing.css
Traceback (most recent call last):
  File "/builds/slave/fx-team-osx64-0000000000000000/build/toolkit/mozapps/installer/packager.py", line 402, in <module>
    main()
  File "/builds/slave/fx-team-osx64-0000000000000000/build/toolkit/mozapps/installer/packager.py", line 354, in main
    copier.add(mozpack.path.join(binpath, 'removed-files'), removals)
  File "/tools/python/lib/python2.7/contextlib.py", line 24, in __exit__
    self.gen.next()
  File "/builds/slave/fx-team-osx64-0000000000000000/build/python/mozbuild/mozpack/errors.py", line 129, in accumulate
    raise AccumulatedErrors()
mozpack.errors.AccumulatedErrors
make[3]: *** [stage-package] Error 1
make[2]: *** [postflight_all] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I have a similar in https://tbpl.mozilla.org/?tree=Fx-Team&rev=e0638ce22c6e

The error is same, but the file in question is not aboutPrivateBrowsing.css, but SettingsQueue.jsm
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 852669
Comment hidden (Treeherder Robot)
Temporarily disabled bld-lion-r5-091 before I clobbered every trunk tree, in hopes that someone will look at its busted fx-team opt objdir, though maybe this current case from bug 1061888 removing some files from browser/extensions/shumway/ isn't the same as the SettingsQueue.jsm case where the file was removed from moz.build but not removed from the tree, or the original case where bug 1009370 moved aboutPrivateBrowsing.css from skin to content and stopped jarring Privacy-48.png, but didn't remove it.

At any rate, that's what's going on here: removing jarred files requires a clobber on OS X universal builds.
Blocks: 941904
You're right, that was silly of me. We can always find a new bustage when someone actually wants to look.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to TBPL Robot from comment #34)
> submit_timestamp: 2014-12-29T17:36:09
> log:
> https://treeherder.mozilla.org/ui/logviewer.html#?repo=mozilla-
> inbound&job_id=4987728
> repository: mozilla-inbound
> who: wkocher[at]mozilla[dot]com
> machine: bld-lion-r5-003
> buildname: OS X 10.7 mozilla-inbound build
> revision: a90291c04e5b
> 
> IOError: [Errno 2] No such file or directory:
> '/var/folders/ly/7r7cl9tj5sg8c0j11hszlq2000000w/T/tmp4WNwCE.zip'
> make[3]: *** [stage-package] Error 1
> make[2]: *** [postflight_all] Error 2
> make[1]: *** [realbuild] Error 2
> make: *** [build] Error 2
> Return code: 2
> 'mach build' did not run successfully. Please check log for errors.
> Running post_fatal callback...
> Exiting -1
> # TBPL FAILURE #
> # TBPL FAILURE #

Nope, not this bug.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent "package-manifest:439: File missing ... Privacy-48.png, aboutPrivateBrowsing.css" ("make[2]: *** [postflight_all] Error 2") → You need to clobber only the OS X opt build when you hit "package-manifest:439: File missing ... Privacy-48.png, aboutPrivateBrowsing.css, (whatever jarred file someone just removed)" ("make[2]: *** [postflight_all] Error 2")
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 156

3 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* mozilla-b2g37_v2_2: 1
* b2g-inbound: 1

Platform breakdown:
* osx-10-7: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2015-10-19&endday=2015-10-25&tree=all

Comment 157

3 years ago
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 4
* mozilla-inbound: 3

Platform breakdown:
* osx-10-7: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2015-11-02&endday=2015-11-08&tree=all

Comment 158

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* mozilla-inbound: 2
* mozilla-central: 1

Platform breakdown:
* osx-10-7: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2015-11-23&endday=2015-11-29&tree=all
From today's occurrence on m-i, it would seem to be related to universal builds not removing files properly on both ends of the universal build.
... which I now realized is in the bug title.

Comment 161

2 years ago
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 5
* mozilla-beta: 2
* fx-team: 2
* mozilla-aurora: 1

Platform breakdown:
* osx-10-7: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2015-11-30&endday=2015-12-06&tree=all
Duplicate of this bug: 1243744
Summary: You need to clobber only the OS X opt build when you hit "package-manifest:439: File missing ... Privacy-48.png, aboutPrivateBrowsing.css, (whatever jarred file someone just removed)" ("make[2]: *** [postflight_all] Error 2") → You need to clobber only the OS X opt build when you hit "package-manifest:439: File missing (whatever jarred file someone just removed)" ("make[2]: *** [postflight_all] Error 2"/"make: *** [automation/package] Error 2")

Comment 163

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* mozilla-inbound: 2
* mozilla-beta: 1

Platform breakdown:
* osx-10-7: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-02-01&endday=2016-02-07&tree=all

Comment 164

2 years ago
17 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 11
* mozilla-beta: 3
* fx-team: 2
* mozilla-central: 1

Platform breakdown:
* osx-10-7: 17

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-02-08&endday=2016-02-14&tree=all

Comment 166

2 years ago
11 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 7
* mozilla-inbound: 4

Platform breakdown:
* osx-10-7: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-09-26&endday=2016-10-02&tree=all

Comment 167

2 years ago
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 4
* mozilla-inbound: 1
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* osx-10-7: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-10-03&endday=2016-10-09&tree=all

Comment 168

2 years ago
8 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 5
* autoland: 3

Platform breakdown:
* osx-10-7: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-10-17&endday=2016-10-23&tree=all

Comment 169

2 years ago
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 12
* mozilla-inbound: 3
* fx-team: 1

Platform breakdown:
* osx-10-7: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-10-25&endday=2016-10-25&tree=all

Comment 170

2 years ago
21 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 17
* mozilla-inbound: 3
* fx-team: 1

Platform breakdown:
* osx-10-7: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-10-24&endday=2016-10-30&tree=all

Comment 171

2 years ago
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* autoland: 4
* mozilla-central: 2

Platform breakdown:
* osx-10-7: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-10-31&endday=2016-11-06&tree=all
6 failures in 715 pushes (0.008 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 3
* mozilla-inbound: 2
* mozilla-central: 1

Platform breakdown:
* osx-10-7: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-11-14&endday=2016-11-20&tree=all
13 failures in 623 pushes (0.021 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 12
* mozilla-central: 1

Platform breakdown:
* osx-10-7: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-11-21&endday=2016-11-27&tree=all
18 failures in 694 pushes (0.026 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 9
* autoland: 7
* mozilla-central: 2

Platform breakdown:
* osx-10-7: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1059460&startday=2016-11-28&endday=2016-12-04&tree=all
(Reporter)

Comment 175

4 months ago
No longer relevant on branches we care about.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.