Closed Bug 1059484 Opened 8 years ago Closed 8 years ago

Enable sharing on the external storage card called sdcard1

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: dhylands, Assigned: dhylands)

References

Details

Attachments

(2 files)

Currently we enable sharing for external cards called extsdcard and external, but not the ones called sdcard1.
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Comment on attachment 8480106 [details] [diff] [review]
Enable sharing by default for sdcard1 storage area.

redirect to module owner review
Attachment #8480106 - Flags: review?(gasolin) → review?(arthur.chen)
Comment on attachment 8480106 [details] [diff] [review]
Enable sharing by default for sdcard1 storage area.

Looks good to me. But I would like Ian check the patch as I may not be that familiar with the storage things. Thanks.
Attachment #8480106 - Flags: review?(arthur.chen)
Attachment #8480106 - Flags: review+
Attachment #8480106 - Flags: feedback?(iliu)
I would like to know what the use case is preparing for enabled key "ums.volume.sdcard1.enabled"? Is it an another external storage name for specific device? 

As I implemented SD card management user story, I find out external storage has different name on flame/helix. It's a little be confused to me. So I comment some description in Gaia code base.(https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/media_storage.js#L666-L668)
Per comment 4, need info from Dave.
Flags: needinfo?(dhylands)
On the flame, internal storage is called sdcard and external storage is called sdcard1.
Flags: needinfo?(dhylands)
(In reply to Dave Hylands [:dhylands] from comment #6)
> On the flame, internal storage is called sdcard and external storage is
> called sdcard1.

Just check the storage name again. My observation is not matching with yours. I put some console log in `settings.gaiamobile.org/js/media_storage.js` while creating view. Looks like the name of external storage of Flame is 'external'. It's sync to comment 4.

E/GeckoConsole( 5436): Content JS LOG at app://settings.gaiamobile.org/js/media_storage.js:513 in ms_initAllVolumeObjects: --> name = sdcard
E/GeckoConsole( 5436): Content JS LOG at app://settings.gaiamobile.org/js/media_storage.js:513 in ms_initAllVolumeObjects: --> name = external


I'm not sure that you cannot enable sharing on the external storage card on flame only or not. Some people have the problem before [SD card manage] user story landed. I remember Alphan told me it's relative with kernel source code in Gonk (bug 1054131). But bug 1054131 is not only for external storage.
My flame was flashed with the v123 base image.

I built it from source using the latest master earlier today and did a full flash.

These are the volume names reported by vold, which is what Device Storage uses.

> 2001 >adb shell vdc volume list
> 110 0 sdcard /storage/sdcard 4
> 110 0 sdcard1 /storage/sdcard1 4
> 200 0 Volumes listed.

It's entirely possible that a different base image may be reporting different volume names (since the volume names are rather arbitrary).

I've definitely enabled the external SD card with UMS in the past, and it seems to work fine using the v123 base image.
Comment on attachment 8480106 [details] [diff] [review]
Enable sharing by default for sdcard1 storage area.

According to your comment, it's entirely possible to have different volume names for different image. Base on the functionality, I feedback +. But, we might have to find a better solution for management storage name. Otherwise, there will be more key name for different image.
Attachment #8480106 - Flags: feedback?(iliu) → feedback+
Dave, would you keep to land the patch? Thanks.
Flags: needinfo?(dhylands)
https://github.com/mozilla-b2g/gaia/commit/d450b8587b8255545cfd16b0785671e832f6cb5f
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(dhylands)
Resolution: --- → FIXED
[Blocking Requested - why for this release]:
Please uplift this fix to 2.1 since this change would cause external SD card could not be detected.
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Storage]
Flags: needinfo?(dhylands)
Comment on attachment 8480106 [details] [diff] [review]
Enable sharing by default for sdcard1 storage area.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Always been present on flame
[User impact] if declined: Unable to share external sdcard with PC
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Very Low
[String changes made]: None
Attachment #8480106 - Flags: approval-gaia-v2.1?
Flags: needinfo?(dhylands)
Attachment #8480106 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Duplicate of this bug: 1066128
brogan, please verify this bug is fixed on 2.1 in tomorrow's build.  also verify the dupe bug 1066128 is fixed as well.   thanks.
Flags: needinfo?(bzumwalt)
Keywords: verifyme
blocking-b2g: 2.1? → 2.1+
Issue still occurs on Flame KK build 20140925000204 after full flash

User cannot see sdcard1 when USB sharing is enabled. In addition, sdcard0 (internal) appears only briefly before disappearing and has only a single corrupted file within.

This occurs on multiple devices tested on multiple computers.

Device: Flame 2.1 KK (319mb)
BuildID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(bzumwalt)
QA Whiteboard: [COM=Storage] → [COM=Storage][QAnalyst-Triage?]
Attached file Logcat
Attached logcat of current issue
Brogan - I think that you're most likely seeing bug 1066128 (and not this bug) They both have the same symptoms, but different causes.
In that case un-duping bug 1066128 given the evidence that this patch doesn't fix bug 1066128.
The symptom described in comment 17 is fixed by bug 1066128
QA Whiteboard: [COM=Storage][QAnalyst-Triage?] → [QAnalyst-Triage?]
This issue is verified as fixed for the latest 2.1 and 2.2 builds:

Environmental Variables:
----------------------------------------
Device: Flame 2.1
BuildID: 20141013001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
----------------------------------------
Device: Flame 2.2 Master
BuildID: 20141013040202
Gaia: 3b81896f04a02697e615fa5390086bd5ecfed84f
Gecko: f547cf19d104
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

adb shell vdc volume list returns:
110 0 sdcard /storage/sdcard 4
110 0 sdcard1 /storage/sdcard1 0
200 0 Volumes listed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.