Structured logging fails to recognize test timeouts (and crashes?)

RESOLVED DUPLICATE of bug 1028327

Status

Testing
Mochitest
--
major
RESOLVED DUPLICATE of bug 1028327
4 years ago
4 years ago

People

(Reporter: drno, Assigned: akachkach)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This is the try run: https://tbpl.mozilla.org/?tree=Try&rev=7be3a1c90633

Pay close attention to B2G ICS Emulator Debug M(9) being green. If you click on the build log you will get this: https://tbpl.mozilla.org/php/getParsedLog.php?id=46882683&tree=Try&full=1

And notice that there was at least a test timeout of some sort. Not sure if there was also a crash which went unnoticed.
(Assignee)

Comment 1

4 years ago
After discussing this on IRC, it seems this is done on purpose to hide a perma-orange (bug 1028119).
This is a known issue, this has been failing forever but was exposed somewhat recently. Not all mochitest failures are structured logging related :).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028327
You need to log in before you can comment on or make changes to this bug.