Event in a CalDAV calendar: if None was selected for Alarm, it changes unexpectedly to Custom

RESOLVED INVALID

Status

Calendar
Alarms
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Jocelyn Viau, Unassigned)

Tracking

Lightning 3.3
x86_64
Windows 8.1

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Steps to reproduce:

Set the default Alarm for an event to None in the configuration.
Have a CalDAV calendar (a Google calendar in my case).
Create an event and leave the Alarm to None.


Actual results:

The event is saved to the CalDAV calendar. A bell icon appears on the event in the calendar view suggesting that an Alarm is set for the event even if None was choosen.

When returning into the event properties, the Alarm is changed to Custom and set to 30 minutes before. If I leave it that way, an Alarm will indeed pop up 30 minutes before the event. If I choose None again for the Alarm and save the event, then it stays to None and the bell icons disappears.

However, if I choose something else than None for the alarm when creating the event, the choice is saved correctly and the alarm pops up as expected.


Expected results:

When selecting None for the Alarm for an event in a CalDAV calendar, the alarm should stay set to None and the bell icon should not appear in the calendar view.
(Reporter)

Updated

3 years ago
OS: All → Windows 8.1
Hardware: All → x86_64

Comment 1

3 years ago
This is a known problem of Google Calendar if you enabled default reminder in the Google Calendar web interface for this calendar. If you specify no reminder in Lightning than Google will just add one for you.
(Reporter)

Comment 2

3 years ago
You are right, removing all default reminders from Google Calendar web interface, which are set to 30 minutes, solves the problem.

This behavior is not a bug in Lightning but I think it should be documented in a FAQ somewhere. Is there a place on the Lightning support pages?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.