Closed Bug 1059745 (Albanian-WordPrediction) Opened 5 years ago Closed 5 years ago

Albanian word suggestion

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: delphine, Assigned: rudyl)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

Albanian is a Tako requirement for 2.1. 
It seems we don't have word suggestion yet (https://github.com/mozilla-b2g/gaia/tree/master/apps/keyboard/js/imes/latin/dictionaries) so opening this bug to track work and progress.
[Blocking Requested - why for this release]: Tako requirement
blocking-b2g: --- → 2.1?
Hi Bruce, can you clarify Comment 1 ? Thanks.
Flags: needinfo?(bhuang)
Flags: needinfo?(bhuang)
Triage: This is a 2.1 requirement, blocking.
blocking-b2g: 2.1? → 2.1+
(In reply to Rudy Lu [:rudyl] from comment #3)
> The work to create the layout is in bug 1059745.

Corrected: layout work is bug 964816.
Assignee: nobody → rlu
Attached file Patch V1
Patch to add Albanian dictionary.
This depends on the layout work, and it still needs feedback to land.
Status: NEW → ASSIGNED
Whiteboard: [p=1]
Target Milestone: --- → 2.1 S5 (26sep)
Comment on attachment 8493527 [details] [review]
Patch V1

Jan, please help review this.
Attachment #8493527 - Flags: review?(janjongboom)
Comment on attachment 8493527 [details] [review]
Patch V1

r=me for the dictionary part. Accent handling is also fine.
Attachment #8493527 - Flags: review?(janjongboom) → review+
This is still waiting for layout work, bug 964816 to land first, but that would need some time to get consensus.
Rudy, any update? Do you reach a consensus?
Flags: needinfo?(rlu)
Hi Ken,
Yes, we've had a consensus to land my proposed layout in bug 964816 first, and then this bug can land.
The patch in bug 964816 is waiting for review.

Thanks.
Flags: needinfo?(rlu)
https://github.com/mozilla-b2g/gaia/commit/368574bc954bdda795d35c69a3110c53b3a8707c

--
Thanks.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: 2.1 S5 (26sep) → 2.1 S6 (10oct)
Comment on attachment 8493527 [details] [review]
Patch V1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): A feature request for product requirement.
[User impact] if declined: No word suggestion for Albanian users.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): low, adding the dictionary data.
[String changes made]: N/A
Attachment #8493527 - Flags: approval-gaia-v2.1?
Whiteboard: [p=1] → [p=1], NO_UPLIFT
Attachment #8493527 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Uplifted to v2.1,
198d7433295dea771ecb0369e03f1e8e5d69bcb3
Whiteboard: [p=1], NO_UPLIFT → [p=1]
This is verified fixed on Flame 2.1 and Flame 2.2

The Albanian keyboard is properly displayed, and when the user types the auto correct bar will appear and function as intended


Flame 2.1

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.2

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Alias: Albanian-WordPrediction
You need to log in before you can comment on or make changes to this bug.