Change [Upload New Version] label to [Add a new file] when viewing a version

RESOLVED DUPLICATE of bug 1019153

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED DUPLICATE of bug 1019153
3 years ago
2 years ago

People

(Reporter: anaran, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8480547 [details]
Add a new Version

Link
Upload New Version
https://addons.allizom.org/en-US/developers/addon/jot/versions#version-upload

shows different UI when clicked from

Status & Versions
https://addons.allizom.org/en-US/developers/addon/jot/versions

See atttachment titled: Add a new Version

as opposed to

Manage Version 0.3.14
https://addons.allizom.org/en-US/developers/addon/jot/versions/1529319

See atttachment titled: Upload a new file

Details:

Upload a New VersionUpload New Version
(Reporter)

Updated

3 years ago
Attachment #8480547 - Attachment description: aanv.png → Add a new Version
(Reporter)

Comment 1

3 years ago
Created attachment 8480548 [details]
Upload a new file
(Reporter)

Updated

3 years ago
Summary: Suggested Solution or Problem Statement → Make link [Upload New Version] never provide [Add a new file] Dialog
(Reporter)

Updated

3 years ago
Summary: Make link [Upload New Version] never provide [Add a new file] Dialog → Make link [Upload New Version] always provide [Add a new Version] dialog, never [Upload a new file]
Humm, I may be missing something, but this doesn't seem to be a bug for me.
Those are two distinct actions:

- upload a new version means adding a new version, like 0.2 instead of 0.1

- upload a new file means adding a new file for a given version, like a file for Mac while you first uploaded a file for Linux for example, but still for the version 0.1.
(Reporter)

Comment 3

3 years ago
The problem is that following [link] (same URL) performs different actions, despite always being called "Upload New Version"!

This can't be right!

E.g. https://addons.mozilla.org/en-US/developers/addon/jot/versions
has this on the left side:

Jot

    Status: Preliminarily Reviewed and Awaiting Full Review ?
    Current Version: 0.3.14 ?
    Last Updated: Aug 28, 2014
    Next Version: 0.3.15 ?
    Queue Position: 120 of 121

[Upload New Version] ยท View All
> The problem is that following [link] (same URL) performs different actions, despite always 
> being called "Upload New Version"!

This one is a bug :)

Updated

3 years ago
Summary: Make link [Upload New Version] always provide [Add a new Version] dialog, never [Upload a new file] → Change [Upload New Version] label to [Add a new file] when viewing a version
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1019153
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.