Closed Bug 1059766 Opened 7 years ago Closed 7 years ago

Tap on bluetooth item closes Settings app and redirects to Homescreen

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1053107

People

(Reporter: viorela, Unassigned)

Details

(Keywords: regression, Whiteboard: [fromAutomation][systemsfe])

Attachments

(1 file)

When in Settings app, if we tap on bluetooth, the Setting app is closed and the homescreen is displayed instead. 
If we hold the home button in order to see the running apps, we will get a message that there is no running app. 

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette_test.py", line 171, in run
testMethod()
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_bluetooth.py", line 30, in test_toggle_bluetooth_settings
bluetooth_settings = settings.open_bluetooth_settings()
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py", line 129, in open_bluetooth_settings
self._tap_menu_item(self._bluetooth_menu_item_locator)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py", line 199, in _tap_menu_item
self._wait_for_parent_section_not_displayed(menu_item)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py", line 194, in _wait_for_parent_section_not_displayed
lambda m: parent_section.location['x'] + parent_section.size['width'] == 0)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 54, in wait_for_condition
Wait(self.marionette, timeout).until(method, message=message)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/wait.py", line 122, in until
rv = condition(self.marionette)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py", line 194, in <lambda>
lambda m: parent_section.location['x'] + parent_section.size['width'] == 0)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette.py", line 169, in location
return self.marionette._send_message("getElementLocation", "value", id=self.id)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/decorators.py", line 35, in _
return func(*args, **kwargs)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette.py", line 634, in _send_message
self._handle_error(response)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette.py", line 709, in _handle_error
raise errors.MarionetteException(message=response, status=500)
MarionetteException: MarionetteException: {u'message': u'"toString" is read-only', u'error': u"error occurred while processing 'getElementLocation"}

Last working: 
Device firmware (date) 	27 Jun 2014 00:57:58
Device firmware (incremental) 	110
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	27 Aug 2014 20:16:03
Gaia revision 	39cad6c82122
Gecko build 	20140827205146
Gecko revision 	a2d24399428a
Gecko version 	34.0a1

First failing:
Device firmware (date) 	27 Jun 2014 00:57:58
Device firmware (incremental) 	110
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	27 Aug 2014 20:16:03
Gaia revision 	39cad6c82122
Gecko build 	20140827210249
Gecko revision 	52b00288469c
Gecko version 	34.0a1

The issue is reproducible locally, by running the automated test, and also manually. The test is not failing on v2.0.

#STR:
1. Open settings app
2. Tap Bluetooth item

#Expected results:
Bluetooh page is displayed

#Actual results:
Settings app closes and homescreen is displayed.

Jenkins run: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame.b2g-inbound.ui.functional.smoke/1088/HTML_Report/
Can we get a logcat? there'll probably be a juicy error in the logcat.
Attached file logcat
Whiteboard: [fromAutomation]
When you tap on the Bluetooth item in Settings this error message occurs:
E/GeckoConsole(10510): [JavaScript Error: "NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXULAppInfo.ID]" {file: "resource://gre/modules/Webapps.jsm" line: 97}]
Keywords: regression
Gaia commits are the same, so this is a gecko regression.
[Blocking Requested - why for this release]:

Bad regression that breaks Bluetooth functionality in the settings app.
blocking-b2g: --- → 2.1?
Flags: needinfo?(kyle)
(In reply to Jason Smith [:jsmith] from comment #6)
> [Blocking Requested - why for this release]:
> 
> Bad regression that breaks Bluetooth functionality in the settings app.

Oh & putting needinfo on Kyle since he's the author of the patches involved in the window above.
Whiteboard: [fromAutomation] → [fromAutomation][systemsfe]
(In reply to Jason Smith [:jsmith] from comment #7)
> (In reply to Jason Smith [:jsmith] from comment #6)
> > [Blocking Requested - why for this release]:
> > 
> > Bad regression that breaks Bluetooth functionality in the settings app.
> 
> Oh & putting needinfo on Kyle since he's the author of the patches involved
> in the window above.

Kyle mentioned in IRC it's likely either bug 846200 or bug 900551.
Component: Gaia::Settings → DOM: Device Interfaces
Flags: needinfo?(kyle)
Product: Firefox OS → Core
Version: unspecified → Trunk
Fixed via backout.

http://hg.mozilla.org/integration/b2g-inbound/rev/7c97c5f7a05e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 2.1? → ---
I just tried this on a flame without the settings patches, and it's still crashing. Can someone else please verify?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flagging qawanted to test this on the latest b2g-inbound build.
Keywords: qaurgent, qawanted
[Blocking Requested - why for this release]:

See comment 6
blocking-b2g: --- → 2.1?
QA Contact: jmercado
This issue does occur on the latest B2G Inbound Flame build.

Environmental Variables:
Device: Flame Master
BuildID: 20140828043849
Gaia: 2898a783e5326c051980e8b1248ee2afcee770f2
Gecko: 645a464cbf93
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
The only other bug left in the push log that's not a test only patch here is bug 1015518, so maybe that's the cause of the regression?
Blocks: 1015518
(In reply to Jayme Mercado [:JMercado] from comment #13)
> This issue does occur on the latest B2G Inbound Flame build.

I just tested this - this works for me on the latest b2g-inbound build. Can you retest?
Keywords: qaurgent, qawanted
No longer blocks: 1015518
(In reply to Jason Smith [:jsmith] from comment #15)
> (In reply to Jayme Mercado [:JMercado] from comment #13)
> > This issue does occur on the latest B2G Inbound Flame build.
> 
> I just tested this - this works for me on the latest b2g-inbound build. Can
> you retest?

There was a few more builds since my original comment and on the new latest build this issue does NOT occur.

Environmental Variables:
Device: Flame Master
BuildID: 20140828134655
Gaia: 0b452c056dc95a1b19e788c3ae0917ce88980a79
Gecko: fa8cf71f64ff
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Keywords: qaurgent, qawanted
Okay - then re-closing as fixed via backout.
Status: REOPENED → RESOLVED
blocking-b2g: 2.1? → ---
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to Jason Smith [:jsmith] from comment #14)
> The only other bug left in the push log that's not a test only patch here is
> bug 1015518, so maybe that's the cause of the regression?

That was backed out also. The backout happened in 2 steps 'cause I explained it to RyanVM incorrectly. Anyways, I'll test on my flame again before relanding just in case, but I'm still iffy as to whether the settings stuff caused this. Didn't see any direct causes.
Just tried this on device using commit a57d1aa27da9 (no settings changes involved), still seeing crashes whenever I open either the bluetooth or wifi panels in settings.

Note that this only happens in OOP instances, either on device or running b2g desktop OOP. B2G desktop in-process seems ok.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Here's the gecko log when I tap bluetooth:

V/EventHub(  305): /dev/input/event0 got: time=122.265069, type=3, code=57, value=0
V/EventHub(  305): /dev/input/event0 got: time=122.265150, type=3, code=53, value=252
V/EventHub(  305): /dev/input/event0 got: time=122.265202, type=3, code=54, value=516
V/EventHub(  305): /dev/input/event0 got: time=122.265250, type=3, code=48, value=30
V/EventHub(  305): /dev/input/event0 got: time=122.265297, type=3, code=50, value=30
V/EventHub(  305): /dev/input/event0 got: time=122.265356, type=0, code=0, value=0
V/EventHub(  305): /dev/input/event0 got: time=122.331666, type=3, code=57, value=-1
V/EventHub(  305): /dev/input/event0 got: time=122.331744, type=0, code=0, value=0
I/Gecko   ( 1255): [Child 1255] WARNING: Transparent content with displayports can be expensive.: file ../../../layout/base/nsDisplayList.cpp, line 1313
I/Gecko   ( 1255): [Child 1255] WARNING: Transparent content with displayports can be expensive.: file ../../../layout/base/nsDisplayList.cpp, line 1313
I/Gecko   ( 1255): ++DOCSHELL 0xb0c25000 == 2 [pid = 1255] [id = 2]
I/Gecko   ( 1255): ++DOMWINDOW == 3 (0xb2fa88c0) [pid = 1255] [serial = 4] [outer = 0x0]
I/Gecko   (  305): [Parent 305] ###!!! ASSERTION: old rule tree still referenced: 'Not Reached', file ../../../layout/style/nsStyleSet.cpp, line 1969
I/Gecko   ( 1255): [Child 1255] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file ../../../toolkit/xre/nsXREDirProvider.cpp, line 1333
I/Gecko   ( 1255): [Child 1255] WARNING: No inner window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9689
E/GeckoConsole( 1255): [JavaScript Error: "NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXULAppInfo.ID]" {file: "resource://gre/modules/Webapps.jsm" line: 97}]
E/GeckoConsole( 1255): [JavaScript Warning: "variable data redeclares argument" {file: "chrome://global/content/BrowserElementPanning.js" line: 515 column: 8 source: "    let data = data.json;
E/GeckoConsole( 1255): "}]
I/Gecko   ( 1255): ############################### browserElementPanning.js loaded
I/Gecko   ( 1255): ######################## BrowserElementChildPreload.js loaded
I/Gecko   ( 1255): [Child 1255] WARNING: Subdocument container has no frame: file ../../../layout/base/nsDocumentViewer.cpp, line 2515
I/Gecko   ( 1255): ++DOMWINDOW == 4 (0xb2fa8aa0) [pid = 1255] [serial = 5] [outer = 0xb2fa88c0]
I/Gecko   (  305): 
I/Gecko   (  305): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x680013,name=PNecko::Msg_PRemoteOpenFileConstructor) Value error: message was deserialized, but contained an illegal value
I/Gecko   (  305): 
I/Gecko   (  305): 
I/Gecko   (  305): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  305):
Note that this is also on debug builds, on flame. Haven't tried on release yet.
Ok, this has been going on for a while in bug 1053107, marking dupe
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1053107
You need to log in before you can comment on or make changes to this bug.