Bug 1059784 (ServiceWorkers-v1)

[meta] Ship Service Workers on desktop on the release channel

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
5 years ago
2 months ago

People

(Reporter: overholt, Unassigned)

Tracking

(Blocks 2 bugs, {dev-doc-complete, meta})

unspecified
Points:
---
654579, AsyncIDB, NavigationController, 931249, 984050, 995484, 1037739, 1040924, 1041339, 1041340, 1043701, 1052935, 1052936, 1058311, 1065216, 1080109, 1080110, 1092832, 1098327, serviceworker-cache, 1112469, 1113003, 1113515, 1113577, 1113582, 1113587, 1113619, 1113621, 1113627, 1113631, 1115820, 1119729, 1119763, 1121157, 1122161, 1122917, 1123593, 1123675, 1124170, 1126483, 1130065, 1130686, 1130688, 1130803, 1131271, 1131352, 1131874, 1131882, 1132141, 1132673, 1133238, 1133242, 1133541, 1133763, 1133805, 1134324, 1134325, 1134841, 1134843, 1134951, 1136044, 1136066, 1136200, 1136467, 1136627, 1136757, 1136780, 1137287, 1137398, 1137408, 1137419, 1137477, 1137816, 1138916, 1139425, 1139513, 1139561, 1139990, 1140782, 1141256, 1141274, 1142015, 1142727, 1142803, 1143981, 1146158, 1146169, 1147746, 1147866, 1148942, 1152508, 1153484, 1154268, 1154900, 1156847, 1157283, 1157467, 1157619, 1157943, 1158728, 1158735, 1159274, 1159378, 1159407, 1159813, 1162018, 1162088, 1163545, 1163829, 1163945, 1164065, 1166504, 1167296, 1167325, 1167808, 1167809, 1168208, 1170550, 1170822, 1170937, 1171486, 1172110, 1172542, 1172884, 1172948, 1173240, 1173361, 1173378, 1173811, 1173912, 1173934, 1174301, 1174381, 1174872, 1175570, 1176988, 1178508, 1179197, 1179396, 1179397, 1179399, 1179401, 1179567, 1179685, 1179706, 1179772, 1179848, 1180765, 1180886, 1181887, 1182087, 1182091, 1182103, 1182112, 1182113, 1182118, 1182120, 1183162, 1183983, 1184557, 1184798, 1184855, 1184967, 1185558, 1185640, 1186589, 1187347, 1187350, 1187470, 1187766, 1187950, 1188062, 1189534, 1189659, 1190703, 1193767, 1193911, 1194847, 1194848, 1194881, 1197421, 1198078, 1198394, 1199049, 1200053, 1200677, 1201498, 1201747, 1201962, 1202001, 1202085, 1203359, 1203680, 1203760, 1204596, 1205302, 1205321, 1205676, 1206124, 1206185, 1206298, 1207727, 1208559, 1210077, 1210609, 1212904, 1213150, 1214772, 1215140, 1215230, 1215601, 1216697, 1217367, 1217501, 1217909, 1218135, 1218139, 1218142, 1218146, 1218499, 1219852, 1220261, 1220678, 1220728, 1221279, 1221351, 1222619, 1223116, 1223378, 1224941, 1226441, 1226686, 1227932
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 44+)

Details

Reporter

Description

5 years ago
We plan to deliver a large chunk of Service Worker functionality by the end of September 2014 on mozilla-central.  This bug tracks that "minimum viable" set of functionality.

It will be exposed behind a pref (as it is now): dom.serviceWorkers.enabled.
Reporter

Updated

5 years ago
Blocks: ServiceWorkers
No longer blocks: 1053255
Reporter

Updated

5 years ago
Blocks: 1050924
Reporter

Comment 2

5 years ago
(In reply to Andrew Overholt [:overholt] from comment #0)
> We plan to deliver a large chunk of Service Worker functionality by the end
> of September 2014 on mozilla-central.  This bug tracks that "minimum viable"
> set of functionality.
> 
> It will be exposed behind a pref (as it is now): dom.serviceWorkers.enabled.

Obviously we didn't make the end of September date but work is still progressing on Maple:  https://treeherder.mozilla.org/ui/#/jobs?repo=maple
Depends on: serviceworker-cache
No longer depends on: 940273
Depends on: 1136044
Depends on: 1136066
Depends on: 1136467
Depends on: 1136627
No longer depends on: 1038973
No longer depends on: 1108181
Depends on: 1138916
Depends on: 1139425

Updated

4 years ago
Depends on: 1133763

Updated

4 years ago
Depends on: 1141256

Updated

4 years ago
Depends on: 1141274
Depends on: 1142015
Depends on: 1134324
Depends on: 1134325

Updated

4 years ago
Depends on: 1146158

Updated

4 years ago
Depends on: 1146169

Updated

4 years ago
Depends on: 1147746

Updated

4 years ago
Depends on: 1147866

Updated

4 years ago
Depends on: 1148942
Depends on: 1154754

Updated

4 years ago
Depends on: 1154900

Updated

4 years ago
Depends on: 1156092
Depends on: 1156198
Depends on: 1157283

Updated

4 years ago
Depends on: 1157467
Depends on: 1158728
Depends on: 1158735

Updated

4 years ago
Depends on: 1159378
No longer blocks: 1159407

Updated

4 years ago
Depends on: 1159813

Updated

4 years ago
Depends on: 1162018
Depends on: 1164065

Updated

4 years ago
Depends on: 1163945

Updated

4 years ago
Depends on: 1163829

Updated

4 years ago
Depends on: 1168208
Depends on: 1168226
Depends on: 1155153
No longer depends on: 1169249

Updated

4 years ago
Depends on: 1170550

Updated

4 years ago
Depends on: 1170795

Updated

4 years ago
Depends on: 1171486

Updated

4 years ago
Depends on: 1172110

Updated

4 years ago
Depends on: 1173240

Updated

4 years ago
Depends on: 1173378
Depends on: 1173361

Updated

4 years ago
Depends on: 654579
Reporter

Updated

4 years ago
No longer depends on: 1056702
Reporter

Updated

4 years ago
No longer depends on: 1125961

Updated

4 years ago
No longer depends on: 1130687

Updated

4 years ago
No longer depends on: 1134329

Updated

4 years ago
No longer depends on: 1137245

Updated

4 years ago
No longer depends on: 1154754

Updated

4 years ago
No longer depends on: 1155153

Updated

4 years ago
No longer depends on: 1160527
Component: DOM → DOM: Service Workers

Updated

4 years ago
No longer depends on: 1168226

Updated

4 years ago
No longer depends on: 1170543

Updated

4 years ago
No longer depends on: 1170795

Updated

4 years ago
No longer depends on: 1172992

Updated

4 years ago
Summary: [meta] Service Worker v1 → [meta] Ship Service Workers on desktop and Android on the release channel

Updated

4 years ago
No longer depends on: 1174140
Release Note Request (optional, but appreciated)
[Why is this notable]: Shipping Service Workers
[Suggested wording]:
[Links (documentation, blog post, etc)]:

I'm going to need help with the note when the time comes to note this.
relnote-firefox: --- → ?
No longer depends on: 1174299
Ehsan, Andrew: Would you be able to provide a suggested wording on this one for inclusion in release notes for Firefox 41? Thanks in advance!
Flags: needinfo?(overholt)
Flags: needinfo?(ehsan)
Ritu, we decided not to ship this in FF41.  So I don't think it should not be included in the release notes.
Flags: needinfo?(overholt)
Flags: needinfo?(ehsan)
Depends on: 1179396
Depends on: 1179397
Depends on: 1179399
Depends on: 1179401
(In reply to Ben Kelly [:bkelly] from comment #5)
> Ritu, we decided not to ship this in FF41.  So I don't think it should not
> be included in the release notes.

Got it. Thanks!

Updated

4 years ago
Depends on: 1179567
Depends on: 1179685
Depends on: 1179706
No longer depends on: 1179706
Depends on: 1179772
Depends on: 1179806

Updated

4 years ago
Depends on: 1180274
Depends on: 1180622
Depends on: 1180638
Depends on: 1180731

Updated

4 years ago
Depends on: 1181887
Depends on: 1182087
Depends on: 1182091
Depends on: 1182095
Depends on: 1182103
Depends on: 1182110
Depends on: 1182112
Depends on: 1182113
Depends on: 1182118
Depends on: 1182120
Depends on: 1184557

Updated

4 years ago
No longer depends on: 1180274

Updated

4 years ago
Depends on: 1184855

Updated

4 years ago
No longer depends on: 1185558

Updated

4 years ago
No longer depends on: 1179806

Updated

4 years ago
Depends on: 1186589
Depends on: 1187766

Updated

4 years ago
Depends on: 1187948

Updated

4 years ago
Depends on: 1187950

Updated

4 years ago
Depends on: 1187951

Updated

4 years ago
Depends on: 1188062

Updated

4 years ago
No longer depends on: 1187948
Depends on: 1188822
Depends on: 1189534
No longer depends on: 1180622
No longer depends on: 1180638
No longer depends on: 1180731
No longer depends on: 1188822
No longer depends on: 1184607
Depends on: 1194847
Depends on: 1178713
Depends on: 1194881
Depends on: 1194848
No longer depends on: 1195980
Depends on: 1197421

Updated

4 years ago
Depends on: 1198394

Updated

4 years ago
Depends on: 1198397
Reporter

Updated

4 years ago
No longer depends on: 1162772
Reporter

Updated

4 years ago
No longer depends on: 1178713
Reporter

Updated

4 years ago
No longer depends on: 1182095
Reporter

Updated

4 years ago
No longer depends on: 1186106
Reporter

Updated

4 years ago
No longer depends on: 1187300
Reporter

Updated

4 years ago
No longer depends on: 1189945

Updated

4 years ago
No longer depends on: 1198397

Updated

4 years ago
Depends on: 1201160
Depends on: 1201747
No longer depends on: 1202666
No longer depends on: 1093357
Depends on: 1203760

Updated

4 years ago
Depends on: 1199049

Updated

4 years ago
No longer depends on: 1194384
No longer depends on: 1134372

Updated

4 years ago
Depends on: 1204596
Reporter

Updated

4 years ago
No longer depends on: 1182110
Reporter

Updated

4 years ago
Depends on: 1205302

Updated

4 years ago
Depends on: 1205321
Release Note Request (optional, but appreciated)
[Why is this notable]: suggested by dev team
[Suggested wording]: 	Service worker network interception via FetchEvent enabled
[Links (documentation, blog post, etc)]:   https://developer.mozilla.org/en-US/docs/Web/API/FetchEvent or maybe the main MDN service workers page?

Let me know if you want different wording and whether to link to the FetchEvent page or not. Thanks!
Depends on: 1206011
No longer depends on: 1206011

Comment 8

4 years ago
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #7)
> Release Note Request (optional, but appreciated)
> [Why is this notable]: suggested by dev team
> [Suggested wording]: 	Service worker network interception via FetchEvent
> enabled
> [Links (documentation, blog post, etc)]:  
> https://developer.mozilla.org/en-US/docs/Web/API/FetchEvent or maybe the
> main MDN service workers page?
> 
> Let me know if you want different wording and whether to link to the
> FetchEvent page or not. Thanks!

I think we want to make it clear that this is available in Aurora, since we have not yet made the final call as to whether to let it ride the train all the way to 43 release.
Depends on: 1206185
Depends on: 1206298

Updated

4 years ago
Depends on: 1206458

Updated

4 years ago
No longer depends on: 1206458

Updated

4 years ago
Depends on: 1202052
Reporter

Updated

4 years ago
No longer depends on: 1206298

Updated

4 years ago
No longer depends on: 1187951
Reporter

Comment 9

4 years ago
I split bugs specific to Firefox for Android off into bug 1207262.
No longer depends on: 1202052
Summary: [meta] Ship Service Workers on desktop and Android on the release channel → [meta] Ship Service Workers on desktop on the release channel
Reporter

Updated

4 years ago
Blocks: 1207265

Updated

4 years ago
Depends on: 1207727

Updated

4 years ago
Depends on: 1206458
Depends on: 1208556

Updated

4 years ago
No longer depends on: 1208556

Updated

4 years ago
No longer depends on: 1209445
Depends on: 1210282
No longer depends on: 1206458
No longer depends on: 1210282
Depends on: 1210609

Updated

4 years ago
Depends on: 1213150

Updated

4 years ago
Depends on: 1214305

Updated

4 years ago
Depends on: 1215230

Updated

4 years ago
Depends on: 1215601
Depends on: 1216697

Updated

4 years ago
Depends on: 1185558

Updated

4 years ago
Depends on: 1201498

Updated

4 years ago
Depends on: 1201664

Updated

4 years ago
Depends on: 1202001

Updated

4 years ago
Depends on: 1202085

Updated

4 years ago
Depends on: 1206298

Updated

4 years ago
Depends on: 1215140
Reporter

Updated

4 years ago
Blocks: 1217544
No longer blocks: 1217544

Updated

4 years ago
Depends on: 1188822

Updated

4 years ago
Depends on: 1218135

Updated

4 years ago
Depends on: 1218139

Updated

4 years ago
Depends on: 1218142

Updated

4 years ago
Depends on: 1218146

Updated

4 years ago
Depends on: 1186856

Updated

4 years ago
Depends on: 1218499

Updated

4 years ago
Depends on: 1189659

Updated

4 years ago
No longer depends on: 1189023

Updated

4 years ago
No longer depends on: 1187328

Updated

4 years ago
No longer depends on: 1201160
No longer depends on: 1217456

Updated

4 years ago
Depends on: 1219469
Ehsan, just double checking -- is this still enabled for 43 beta?  I want to make sure to remove the release note if it isn't.
Flags: needinfo?(ehsan)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #10)
> Ehsan, just double checking -- is this still enabled for 43 beta?  I want to
> make sure to remove the release note if it isn't.

Its not enabled in 43 beta.  Please remove from release notes.
Flags: needinfo?(ehsan)
Thanks, I overlooked that note. Fixed now.

Updated

4 years ago
No longer depends on: 901097
No longer depends on: 1220681
Depends on: 1221351
No longer depends on: 1201664
No longer depends on: 1186856
No longer depends on: 1188822
No longer depends on: 1214305
No longer depends on: 1219469

Updated

4 years ago
Depends on: 1201962
No longer depends on: 1226443
Depends on: 1227932

Comment 13

4 years ago
We're shipping in 44.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: ServiceWorkers-Android
Added to the release notes with "Service Workers API" as wording

Comment 17

2 months ago

The defect is since FF44 in progress and service workers are not enabled in the esr release versions per default.
When can you expect them enabled in ESR release per default?

You need to log in before you can comment on or make changes to this bug.