Enable Loop client in early beta or earlier

VERIFIED FIXED in Firefox 33

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mreavy, Assigned: standard8)

Tracking

unspecified
mozilla34
x86_64
Windows 7
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox33 verified, firefox34 verified)

Details

Attachments

(1 attachment)

Loop in Fx33 will be disabled unless we make a small change to the milestone.txt file.  We'd like to keep it on in early Beta and disable it before it goes to release.
Assignee

Comment 1

5 years ago
This switches the ifdef to track for early betas only. I'll request release driver approval once I've got review.
Attachment #8480597 - Flags: review?(ted)
Comment on attachment 8480597 [details] [diff] [review]
Enable Loop on development builds up to early betas.

Review of attachment 8480597 [details] [diff] [review]:
-----------------------------------------------------------------

Not sure why this is r?me (am I a peer for this file?) but you can have r=me for what it's worth. :)
Attachment #8480597 - Flags: review?(ted) → review+
Assignee

Comment 3

5 years ago
Comment on attachment 8480597 [details] [diff] [review]
Enable Loop on development builds up to early betas.

Requesting approval to land in trunk and on aurora as per the rules.

Approval Request Comment
[Feature/regressing bug #]: No specific bug, Loop enabling on Firefox 33
[User impact if declined]: Loop will not be enabled in the early Firefox 33 betas, where we want more users to start trying Loop.
[Describe test coverage new/current, TBPL]: No changes to test coverage, this is just enabling the pref in FF beta and earlier. This has been in test on nightly and aurora for the last 6 weeks
[Risks and why]: The desktop management and Loop teams want to get more testing on the Early betas in FF 33.
[String/UUID change made/needed]: None
Attachment #8480597 - Flags: approval-mozilla-aurora?
Please land that in m-c, I will approve the uplift for aurora right after to make sure it is in beta1.

Lawrence, I approve that on your behalf for 34.
Assignee

Comment 5

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/bab83a083c3a
Assignee: nobody → standard8
Target Milestone: --- → mozilla34
https://hg.mozilla.org/mozilla-central/rev/bab83a083c3a
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8480597 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tracy, can you please make sure this gets verified in the first Beta? The UX is not complete in 33 but users should be able to activate it and have 1:1 calls with friends. Some basic dogfooding should suffice.
Flags: qe-verify+
Flags: needinfo?(twalker)
I've added this verification as a specific item in the smoketest section of the Fx33 test plan.
Flags: needinfo?(twalker)
Marking as verified as per tests performed on Firefox 33 beta 1.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1065063
Florin, can you please make sure this gets verified as part of Firefox 34b1 sign off? The Firefox Hello button should appear in the customize panel by default on new profiles. I believe the button should stay in the toolbar in profiles which have already customized the button to be on the toolbar.

Thanks
Flags: needinfo?(florin.mezei)
Testing was performed for Loop with Firefox 34 Beta 1 build 2 (BuildID=20141014134955), on Windows 7 x64, Windows 8.1 x86, Mac OSX 10.9.5, Ubuntu 14.04 x64:  
- the Hello button displays in the Customize panel by default (if loop.throttled is set to false) 
- if a user from Aurora customizes position for the button in the toolbar, and then uses the same profile in Beta 1, if loop.throttled is true then it's unlikely to get the button. However is the loop.throttled option is overridden in pref.js to false, then the user will correctly see the Hello button at the same position in the toolbar as on Aurora

Tests run can be found at: https://moztrap.mozilla.org/results/cases/?filter-run=5613.

Marking as Verified on 34.
Flags: needinfo?(florin.mezei)

Updated

5 years ago
Iteration: --- → 34.3
You need to log in before you can comment on or make changes to this bug.