Wrong layout with padding, box-sizing: border-box and float: right

RESOLVED DUPLICATE of bug 1059167

Status

()

RESOLVED DUPLICATE of bug 1059167
4 years ago
4 years ago

People

(Reporter: stmoros, Unassigned)

Tracking

34 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140828030205

Steps to reproduce:

1. create an element with a fixed width
2. create another element inside the first one
3. assign the inner element some padding, box-sizing: border-box and float: right

(see http://jsfiddle.net/ppcqtqgt/)


Actual results:

The inner element's right edge is off to the right by the total amount of its horizontal padding. 


Expected results:

The inner element's right edge should be inline with the outer element's right edge.

Updated

4 years ago
Component: Untriaged → Layout
Product: Firefox → Core
Fixed earlier today on inbound.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059167
You need to log in before you can comment on or make changes to this bug.