Drafts/Templates/Sent folders cannot be deleted

VERIFIED DUPLICATE of bug 33235

Status

VERIFIED DUPLICATE of bug 33235
17 years ago
11 years ago

People

(Reporter: 3.14, Assigned: mscott)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

The folders Drafts/Templates/Sent will be newly created after deleting them upon
a news start. I have configured everything in a way that only Trash is used, so
there is no use fort those folders.

Reproducible: Always

1) Account settings / Copies and folders: Set everything to Trash

2) Delete the three folders.

3) Close Mozilla, restart, the folders are back.

pi

Comment 1

17 years ago
Are you talking about the folders under a POP account, IMAP account or Local 
Folders?
(Reporter)

Comment 2

17 years ago
I meant POP Account.

Getting rid of Local Folders (also no use for me) would be another story;-)

pi

Comment 3

17 years ago
Relevant information in bug 33235

(And the local folder is not supposed to be deleted, see bug 23313.
However, there's RFE bug 64716 about the issue.)
(Reporter)

Comment 4

17 years ago
> Relevant information in bug 33235

I don't understand the reasoning, but this here seems to be a duplicate then.

pi

Comment 5

17 years ago
It would be nice to be able to get rid of the unused folders. I have 5 POP
accounts (don't ask why:)) and I have set all the Drafts/Templates/Sent to point
to their Local Folders equivalent. Thus I have 15 folders that are not being
used, but taking up my precious "desktop estate". Hence a big "AYE" from my side
for this bug.

The following approach can be adopted to fix this. At startup, moz checks if
there are any required folders that are to be created. If any required folder
does not exist, create it and don't allow the user to delete it by marking these
folders as special.  Mark all other folders as regular folders allowing the user
to delete them.

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 33235 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.