Review submission has become extremely flaky

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: kmag, Unassigned)

Tracking

Details

(Whiteboard: [qa-])

Attempting to submit a review, for the past couple of weeks, often leads to one or more of the following issues:

1) 504 Gateway Timeout. Sometimes this means the review was not processed successfully. Sometimes it does not. Reloading sometimes leads to duplicate reviews.

2) Multiple copies of the review log, with different timestamps. I initially thought that this was mainly due to people reloading after 504 errors, but I've since confirmed that this is not the case.

3) After submission, we're returned to the review page with the form validation error "File $x.xpi is not pending review". Reloading the page shows that the submission was successful, with the review added to the log, and file statuses updated correctly. Prior to reload, there is no indication that the review was successful.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.