Closed Bug 1060045 Opened 7 years ago Closed 7 years ago

B2G: Can't install 2 apps via rocketbar

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: gwagner, Assigned: kgrandon)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

STR:
With rocketbar search for facebook and click on 'install facebook'
Go back to rocketbar and search for twitter. click on 'install twitter'

Expected: Twitter gets installed

Actual: The tab on twitter doesn't do anything.

Logcat:
I/GeckoDump(  197): XXX FIXME : Got a mozContentEvent: activity-choice
E/QCALOG  (  291): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  291): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
E/GeckoConsole( 2723): Content JS LOG at app://marketplace.firefox.com/main.js:5 in log: [yulelog] Activity name: marketplace-app
E/GeckoConsole( 2723): Content JS LOG at app://marketplace.firefox.com/main.js:5 in log: [yulelog] Activity data: {"slug":"twitter"}
E/GeckoConsole( 2723): Content JS LOG at app://marketplace.firefox.com/main.js:5 in log: [yulelog] postMessaging to https://marketplace.firefox.com: {"name":"marketplace-app","data":{"slug":"twitter"}}
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [installer] app://marketplace.firefox.com origin not allowed
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [webactivities] Received post message from app://marketplace.firefox.com: {"name":"marketplace-app","data":{"slug":"twitter"}}
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [webactivities] Handled "marketplace-app" activity: {"slug":"twitter"}
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [nav] Received navigate event: /app/twitter?src=activity-marketplace-app
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [nav] Updating scrollTop with replaceState
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [nav] Navigation started:  /app/twitter?src=activity-marketplace-app
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [views] Routing /app/twitter
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [req] Opening pool
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [model] app cache miss for key twitter
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [req] GETing https://marketplace.firefox.com/api/v2/fireplace/app/twitter/?cache=1&dev=firefoxos&device=firefoxos&lang=en-US&limit=10&region=restofworld&vary=0
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [model] app cache miss for key twitter
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [model] app cache miss for key twitter
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [model] app cache miss for key twitter
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [req] GETing https://marketplace.firefox.com/api/v2/apps/rating/?app=twitter&dev=firefoxos&device=firefoxos&lang=en-US&limit=10&region=restofworld
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [model] app cache miss for key twitter
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [tracking_events] No associated search term to track.
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [tracking] Tracking page view /app/twitter?src=activity-marketplace-app
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [nav] Navigation loop truncated: 
E/GeckoConsole( 2723): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1409077339910:8 in u/<: [nav] Pushed state onto stack:  /app/twitter
E/LocSvc_ApiV02(  197): I/<--- void globalEventCb(locClientHandleType, uint32_t, locClientEventIndUnionType, void*) line 81 QMI_LOC_EVENT_GNSS_SV_INFO_IND_V02
I can reproduce this as well on the latest b2g-inbound build. From what I can tell, this looks more likely to be a Gaia regression than a Marketplace regression mainly because I'm not even seeing the marketplace app load after selecting install twitter. That implies this is probably a regression in the activity manager in Gaia's window management.

QA Wanted for branch checks.
Component: General → Gaia::System::Window Mgmt
Keywords: qawanted, regression
Product: Marketplace → Firefox OS
Version: Avenir → unspecified
(In reply to Jason Smith [:jsmith] from comment #1)
> I can reproduce this as well on the latest b2g-inbound build. From what I
> can tell, this looks more likely to be a Gaia regression than a Marketplace
> regression mainly because I'm not even seeing the marketplace app load after
> selecting install twitter. That implies this is probably a regression in the
> activity manager in Gaia's window management.
> 
> QA Wanted for branch checks.

I have noticed this some time ago (3-4 weeks) so I don't think this is a recent regression. Forgot to file a bug back then.
I can repro this bug but ONLY if i don't completely close out of the marketplace after installing facebook. If i close the marketplace window completely, marketplace window will open as expected when Install Twitter is tapped. Keeping the marketplace window in the background while trying to tap install twitter will allow this bug to be seen.

This bug repro's on: Flame 2.1, OpenC 2.1

Actual Results: Install Twitter app does not work when accessing from Rocketbar.

Repro Rate: 5/5

Environmental Variables:
Device: Flame Master
BuildID: 20140828040749
Gaia: 39cad6c82122b964f12a66771bfbcc14fb342d9e
Gecko: 2a15dc07ddaa
Version: 34.0a1 (Master) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Open_C Master
Build ID: 20140828040749
Gaia: 39cad6c82122b964f12a66771bfbcc14fb342d9e
Gecko: 2a15dc07ddaa
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL

------------------------------------------------
------------------------------------------------

This bug does NOT repro on: Flame 2.0, Flame 1.4

Actual Result: No issues seen installing Twitter from the Rocketbar.

Repro Rate: 0/4 attempts

Environmental Variables:
Device: Flame 2.0
BuildID: 20140828000650
Gaia: a6fc290a5601183f84ee9c7cb37eeebc933af2f5
Gecko: 625dd5529548
Version: 32.0 (2.0) 
Firmware Version: v123
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
BuildID: 20140827090228
Gaia: 05653cb12d324649687dad3eeb2ea373a2ad84d4
Gecko: baf01c5965ef
Version: 30.0 (1.4) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
[Blocking Requested - why for this release]: This issue should block because it is feasible for new users to start off by installing all their favorite apps. A bug encountered so early in the phone-life-cycle of the user makes for very bad UX
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: croesch
Triage: leave this bug alone because this should be either a [systemsfe] bug or a marketplace bug.
Whiteboard: [systemsfe]
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #5)
> Triage: leave this bug alone because this should be either a [systemsfe] bug
> or a marketplace bug.

This bug is not a marketplace bug. Initial investigation indicates this is something wrong with activity windows not being opened when there is one in the background. Rocketbar could potentially be missing an event.
I have some idea of what's causing this, taking.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S4 (12sep)
Attached file Github pull request
Comment on attachment 8482887 [details] [review]
Github pull request

Hey Ben or Alive - could either of you review this? Thanks!
Attachment #8482887 - Attachment description: WIP - pull request → Github pull request
Attachment #8482887 - Flags: review?(bfrancis)
Attachment #8482887 - Flags: review?(alive)
Comment on attachment 8482887 [details] [review]
Github pull request

clear and reasonable change, r=me.
Attachment #8482887 - Flags: review?(bfrancis)
Attachment #8482887 - Flags: review?(alive)
Attachment #8482887 - Flags: review+
Duplicate of this bug: 1062198
In master: https://github.com/mozilla-b2g/gaia/commit/45d730835c6d905b0d241ae28fecb998c0e856be
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 2.1? → 2.1+
Blocks: 1059482
Issue has been resolved, removing some keywords
Note that due to recent policy changes, all patches need approval for uplift regardless of blocking status. Please request Gaia v2.1 approval on this patch when you get a chance. Sorry for the inconvenience :(
Flags: needinfo?(kgrandon)
Comment on attachment 8482887 [details] [review]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug in feature.
[User impact] if declined: The rocketbar, a core feature of 2.1, will not behave as expected and you will not be able to open results.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Patch is minor, should be no risk.
[String changes made]: none.
Attachment #8482887 - Flags: approval-gaia-v2.1?(bbajaj)
Flags: needinfo?(kgrandon)
Duplicate of this bug: 1062779
Attachment #8482887 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
This bug has been verified fixed in Flame 2.1 and Flame 2.2

If the user installs Facebook, and/or Twitter from the marketplace, they can be found properly place on the homescreen, and functioning as intended

Flame 2.1

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.