Cannot login using Firefox Accounts, no user-visible error

RESOLVED FIXED

Status

Marketplace
Integration
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dethe, Unassigned)

Tracking

2014-Q2
x86
Mac OS X
Points:
---

Details

(Reporter)

Description

4 years ago
Until last week (Friday 2014-08-22) I could login using FxA in my local development environment. As of Monday (2014-08-25), after pulling the latest code from git for both Zamboni and Fireplace, I could no longer log in. The FxA dialog comes up, I can enter my details, it goes away, but the link continues to say "Sign In". In the console I see two messages:

"[login] Not allowing unverified emails"
"[login] Login cancelled"

The first seems to come from `login.js` here: https://github.com/mozilla/fireplace/blob/master/src/media/js/commonplace/login.js#L91 and is kind of puzzling why I would get that message.

The second is confusing because I didn't cancel the login.

Screencast showing the problem: http://www.screencast.com/users/Dethe/folders/Default/media/e74dd46d-3069-4ca1-9ff6-2290acfe5c56

I have tried clearing cookies, cache, and localStorage, as well as testing in a fresh profile and using private browsing mode. All tests using Nightly on a Mac.

Comment 1

4 years ago
I can reproduce locally. I went back quite a few commits in fireplace and I could never get it working. Am I missing something?
https://github.com/mozilla/fireplace/commit/a834a9f1dc06
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.