If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] copylinktext add-on does not work in e10s windows due to SDK context menu bug

RESOLVED DUPLICATE of bug 1060695

Status

Add-on SDK
General
P1
normal
RESOLVED DUPLICATE of bug 1060695
3 years ago
3 years ago

People

(Reporter: mconley, Assigned: zombie)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Copylinktext addon: https://addons.mozilla.org/en-us/firefox/addon/copy-link-text-4750/

Source: https://github.com/brettz9/copylinktext

STR:

1) Install add-on
2) Open e10s window
3) Right click on some link in an e10s window
4) Choose "Copy link text"

ER:

Link text should be copied to clipboard.

AR:

This shows up in the error console:

TypeError:
popupNode is null

filename: resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///Users/mikeconley/Library/Application%20Support/Firefox/Profiles/32tsfewj.e10s/extensions/copylinktext@brett.zamir.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/context-menu.js

stack: "isCurrent@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///Users/mikeconley/Library/Application%20Support/Firefox/Profiles/32tsfewj.e10s/extensions/copylinktext@brett.zamir.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/context-menu.js:112:9updateItemVisibilities@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///Users/mikeconley/Library/Application%20Support/Firefox/Profiles/32tsfewj.e10s/extensions/copylinktext@brett.zamir.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/context-menu.js:1008:49openPopupAtScreen@chrome://global/content/bindings/popup.xml:67:15receiveMessage@chrome://browser/content/tabbrowser.xml:3078:15"

The add-on appears to be doing the right things sending the text from content up to the parent - it looks like the SDK is having a hard time doing things with context menus.
(Assignee)

Updated

3 years ago
Depends on: 1060138
OS: Mac OS X → All
Hardware: x86 → All
This might be a duplicate of some other bug.
Assignee: nobody → tomica+amo
Priority: -- → P1
(Assignee)

Comment 2

3 years ago
yeah bug 1060695
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1060695
You need to log in before you can comment on or make changes to this bug.