If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Failure to open file save dialogue "Save image as"

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Yani, Unassigned)

Tracking

31 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140901] )

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Open image in Facebook, right click, save image as


Actual results:

The dialogue box for the save open but never fills with content. Closing the dialogue crashes Firefox.

Details...

I've seen this maybe 4 times in 3 months. It's not a consistent fault. The same image works from Chrome. Once it occurs restarting Firefox won't clear the error. There is a method to clear the error but I've written up the bug report before I've checked that. 


Expected results:

Image save
(Reporter)

Comment 1

3 years ago
The error persisted after cookies were deleted and when FF reopened in Safe Mode.

Resolved by a reboot. Somewhat drastic.

Comment 2

3 years ago
Do you have crash reports (type about:crashes, bp-...) about this issue?
If yes, paste some URLs here, please.
Flags: needinfo?(akayani)
(Reporter)

Comment 3

3 years ago
I can't be sure this is the related crash report. It is the same day. Seemed to me that it killed the browser without making a report. Unless 4 crashes and 1 report is normal.

https://crash-stats.mozilla.com/report/index/43342a41-784d-44f9-b4a4-3c15a2140829
Flags: needinfo?(akayani)

Comment 4

3 years ago
The CR is empty, so it doesn't provide info.

Comment 5

3 years ago
¬°Hola Yani!

Are you still experiencing this issue?

Is it still crashing?

Please see https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help and provide a few crash IDs

If this is no longer an issue, kindly pick below RESOLVED then WORKSFORME.

¬°Gracias!
Flags: needinfo?(akayani)
Whiteboard: [bugday-20140901] [closeme-20140908]
(Reporter)

Comment 6

3 years ago
I'll have to wait until I see the issue come up again. It was fine in Chrome. I just couldn't get FF to fill the dialog of the save box without a reboot. Even after shutting FF down and reopening in safe mode. All a no go until the computer was rebooted. It kills FF and doesn't even write an error report. 

It's like it is looking for information that isn't initialized. I'll see if the trigger it when FF getting close to a memory excessive memory use.
Flags: needinfo?(akayani)

Comment 7

3 years ago
Resolved per whiteboard
Feel free to reopen if issue returns
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [bugday-20140901] [closeme-20140908] → [bugday-20140901]
(Reporter)

Comment 8

3 years ago
Just spotted this again. FF32.02

I did a screen grab but couldn't save it using Corel Photopaint or Photoshop until after I crashed out of Firefox. 

Looks like there have been some improvements because after crashing and restarting Firefox I could then save the image without a reboot. 

I'll add the image to the top so you can see the actual state of the dialogue.
(Reporter)

Comment 9

3 years ago
Created attachment 8492729 [details]
FFerror.png

Comment 10

3 years ago
For how long you waited in this dialogue? Where you did save previous image?
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(akayani)
Resolution: INCOMPLETE → ---
(Reporter)

Comment 11

3 years ago
The dialogue never fills in, it get to that point then goes unresponsive. (Saving to the desktop.)  

I didn't think that 765MB of memory use was too extreme. Definitely been able to save images with a higher level of memory use. 

The other clue (perhaps) in this is that the image being saved (from Facebook) is open in a JavaScript overlay.  

As you can see it isn't happening that often. I'd have Firefox running for 12+ hours a day and it has taken ~1 month to reappear.
Flags: needinfo?(akayani)

Comment 12

3 years ago
In about:config, what are set for browser.download.dir and browser.download.lastDir?
(Reporter)

Comment 13

3 years ago
Created attachment 8494236 [details]
about:config settings

Comment 14

3 years ago
Okay, I see that you tried Safe Mode, can you try a clean profile? See http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows
(Reporter)

Comment 15

3 years ago
I hope this is not being ignored. It is really (^&%(^$%. It doesn't happen that often but when it does it effect all save dialogues from every application. So any other work becomes unsaveable. 

It is always possible that it isn't a Firefox generated error but Firefox seems to be the common issue. 

I'm sorry I can't be more specific on this. It appears to be related to when Firefox has been going for a bit and is reaching some sort of memory limit. On some occasions the cascade of the error makes it impossible to start Windows Media Center without a reboot.

What might be unusual about this computer?
Uses an SSD boot drive
Has 4 disks in a strip array

Comment 16

3 years ago
(In reply to Phoenix from comment #14)
> Okay, I see that you tried Safe Mode, can you try a clean profile? See
> http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows
^^ this

Updated

3 years ago
Flags: needinfo?(akayani)
(Reporter)

Comment 17

3 years ago
I'm using the 64bit nightly 39.0a1 (2015-03-05)E10s

I haven't seen the issue once. 

And for the record I'll say again... what an outstanding release 39 is shaping up to be. Please make sure everyone knows that I for one think they deserve reward and applause. The last test on Peacekeeper was Chrome 3400 FF39 4400. A really big clap to all of you.
Flags: needinfo?(akayani)

Comment 18

3 years ago
Feel free to reopen, if you see this again
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.