Closed Bug 1060185 Opened 6 years ago Closed 5 years ago

[Messages][SMS] Unable to send MMS from SIM2

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected

People

(Reporter: echang, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached file v2.1_MMS_NOT_SENDING.log (obsolete) —
### STR (might need to change)
1. Have a SIM in SIM2 slot.
2. Send MMS out.
3. Spinning for 5 minutes and got error, unable to send MMS

### Actual
MMS not sent

### Version
Gaia      007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko     https://hg.mozilla.org/mozilla-central/rev/d697d649c765
BuildID   20140828160238
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Sorry, it seems that the debug flags are not enabled in your device.
Is it possible to have the logcat again by applying the script of enable_debug_flags.sh in the following link?
https://github.com/bevis-tseng/Debug_Tools

BTW, is it 100% reproducible?
Flags: needinfo?(echang)
### STR
1. Have 2 SIM in phone.
2. Send MMS out from SIM1 -> okay.
3. Send MMS out from SIM2.
4. Data connection changed request, and tap okay.
4. Spinning for 5 minutes and got error, unable to send MMS
Attachment #8481015 - Attachment is obsolete: true
Flags: needinfo?(echang)
Hi, Bevis, I got new log and new STR, thanks.
Flags: needinfo?(btseng)
Keywords: regression
See Also: → 1060217
Hi Steve,

After checking the log, I found that after MmsService reports "NonActiveSimCardError" when trying to send MMS via non-active SIM, I didn't see further request from Gaia to send MMS again with correct service id.

Could you help to check if there is anything abnormal in gaia-side?

Thanks!
Component: RIL → Gaia::SMS
Flags: needinfo?(btseng) → needinfo?(schung)
From comment 2 - STR
It looks fine from UI, it pops up the sim switching page from SIM1 to SIM2, but the sim label is not changed to SIM2 next to the send arrow(same on v2.0, but it works fine on v2.0).
Is that anything to do with outgoing data default sim switching?
QA Whiteboard: [COM=Gaia::SMS]
Hi Bevis, would it be related to Bug 1058585?
Flags: needinfo?(schung)
I am not sure if it was happened before logs is captured.
I didn't see this symptom of bug 1058585 from the log, because MmsService didn't requested a MMS data connection yet due to non-active SIM being requested from Gaia.
Eric - This seems like quite a bad bug. Shouldn't we nominate this to block 2.1 & work on getting a window (i.e. add regressionwindow-wanted keyword)?
Flags: needinfo?(echang)
Waiting for bug 1058585 to get 2.1+
Flags: needinfo?(echang)
Please ignore c9, just check a couple of builds which are all okay, the latest one is as follows, keep monitoring might be a bug reproduced by running a long time. Need new STR.

V2.1, aurora, Flame
Gaia      bdc36b46ab6993065d36ea3d650b2c38abe51a0d
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/09e070cb6917
BuildID   20140908160204
Version   34.0a2
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.