When restoring the crashed tab in an e10s session, the entire session is restored

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
This is in contrast to what happens after the chrome process crashes.

Updated

4 years ago
tracking-e10s: ? → +
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0

Hello.

I have tested this issue on the latest Nightly (version: 48.0a1, build id: 20160321030217) and could not reproduce it. I crashed a tab using the Crash Me Now! (Simple) and Tab Crasher addons (both can be found at https://addons.mozilla.org/en-US/firefox/search/?q=crashme&appver=48.0&platform=mac) and then I restored the crashed tab. Previously closed tabs were from that session were not restored. Leaving the status as Resolved: Works For Me and removing the qawanted keyword.
If anyone can still reproduce this issue on the latest versions, feel free to reopen this bug.

Thank you.
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.