[Music][System] Media playback control buttons on notification tray is broken

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: chens, Assigned: chens)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1])

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
Created attachment 8481171 [details]
MediaPlaybackControl-before.png

Media playback control show incorrect button on notification tray

Step to reproduce: 
1. Play any music from music app.
2. Pull down notification tray and observe media playback control.

Expected result: 
3. Media playback control display correctly.

Actual result: 
3. Media playback control buttons broken.
(Assignee)

Updated

4 years ago
Assignee: nobody → shchen
(Assignee)

Comment 1

4 years ago
Created attachment 8481178 [details] [review]
Pull request

Dominic, 
Could you review this patch? thanks.
Attachment #8481178 - Flags: review?(dkuo)
(Assignee)

Comment 2

4 years ago
Created attachment 8481179 [details]
MediaPlaybackControl-after.png

Updated

4 years ago
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.1-flame-test-run-1]

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]: Noticeable visible regression.
blocking-b2g: --- → 2.1?
Duplicate of this bug: 1060881

Comment 5

4 years ago
Comment on attachment 8481178 [details] [review]
Pull request

Thanks Sherman, the patch looks good to me, though I didn't actually test it but I believe this should fix it. Also I think it's a regression and would you please help to find the bug that cause this regression? thanks.
Attachment #8481178 - Flags: review?(dkuo) → review+

Updated

4 years ago
Flags: needinfo?(shchen)
Keywords: regression
(Assignee)

Comment 6

4 years ago
Created attachment 8482630 [details]
MediaPlaybackControl-update.png

Not seeing this issue on latest master, music widget has new look and maybe also fix this one.
Flags: needinfo?(shchen)
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.