Consider de-duplicating conversation/websocket code in the routers

RESOLVED DUPLICATE of bug 1088673

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1088673
4 years ago
4 years ago

People

(Reporter: standard8, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tech-debt])

(Reporter)

Description

4 years ago
Bug 1045643 Part 2 added some duplicated code across the routers. At the moment, we don't really have a sane way to work around that without major refactoring.

Possible routes we want to go:

- Create a new Controller class
- Combine the incoming and outgoing routes into one window (which we might need for direct calling)
(Reporter)

Updated

4 years ago
Whiteboard: [tech-debt]

Updated

4 years ago
backlog: --- → Fx36+

Updated

4 years ago
backlog: Fx36+ → Fx37+
(Reporter)

Comment 1

4 years ago
This work will happen as part of bug 1088672 / bug 1088673. Its inherent to the code there, so I don't think we need this separate bug open.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088673
You need to log in before you can comment on or make changes to this bug.