Mochitest should only call suite_start once for a run

REOPENED
Unassigned

Status

defect
REOPENED
5 years ago
4 years ago

People

(Reporter: cmanchester, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Mochitests sometimes calls buildTestPath multiple times, at least when using the bisect chunk code. Right now this is where we call structured logging's suite_start, but mozlog expects just one suite_start and issues an error if it gets called more than once.
Reference Log: https://tbpl.mozilla.org/php/getParsedLog.php?id=47027650&tree=Try&full=1

This line: INFO -  26883 ERROR Got second suite_start message before suite_end
hey guys, lets pick this up and move this along.  Do we know if this is an issue due to instantiating the browser >1 inside a single test job or the issue is somewhere else?
From IRC sounds like Vaibhav would like to take a look at this. I think this will be a matter of logging the suite_start once outside of how buildTestPath is called. The idea is to log just once at the very beginning with a list of all test names to be run. In the case of run-by-dir this sounds like doing so before splitting into directories, and in the case of bisect chunk this sounds like doing so once for the initial run before any rerun during bisection analysis.
assigning to Vaibhav, do let me know if that should not be the case.  There are a handful of bugs like this to get fixed.

Vaibhav, if you feel this is a fairly simple bug, feel free to make this a good first bug and add some links to code and suggestions of what to do!
Assignee: nobody → vaibhavmagarwal
https://tbpl.mozilla.org/?tree=Try&rev=ac137232d8bd -- try push with normal mochitest

https://tbpl.mozilla.org/?tree=Try&rev=c6d839b467b2 -- try push with --bisect-chunk turned on for mochitests
Vaibhav, thanks for working on this bug.

In the bisect chunk bug, i see a bc1 failure and a name error for 'log':
https://tbpl.mozilla.org/php/getParsedLog.php?id=48310873&tree=Try

seems like we could fix that easily :)
https://tbpl.mozilla.org/?tree=Try&rev=ff4de9cd9012 -- try push with --bisect-chunk turned on.

The "Bisection Summary" is getting printed but the summary(passed, failed, todo) is not getting printed for individual runs: https://tbpl.mozilla.org/php/getParsedLog.php?id=48357405&tree=Try&full=1
We discussed some strategies for debugging why the summary isn't printed by the bc harness, but the issue with logging suite_start can be addressed independent of that.
Depends on: 1075240
I believe this was fixed with my patch for bug 1075240, please reopen if there are any issues found related to this.
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1075240
Resolution: --- → DUPLICATE
Duplicate of bug: 1075240
I guess the fix doesn't work with runByDir.
Blocks: 1071227
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 1112609
Duplicate of this bug: 1119833
Don't think I would be working on it anytime soon, clearing the assigned flag.
Assignee: vaibhavmagarwal → nobody
You need to log in before you can comment on or make changes to this bug.