[System] Default voicemail number does not show in logcat

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: rpribble, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1][2.1-flame-test-run-2])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8481680 [details]
Logcat.txt

Description:
The default voicemail number is not fired in the logcat when 1 is long pressed on the dial pad to call the voicemail.

Prerequisite:
1) Have DUT attached to a computer via usb and the logcat open and running.

Repro Steps:
1) Update a Flame device to BuildID: 20140829040202
2) Insert two sims from different MCCs after progressing through FTE
3) Settings > Call settings > Sim 1 > Observe default voicemail number
4) Navigate to dialer
5) Long press 1 to call voicemail and selefct "default"

  
Actual:
The default voicemail number is not shown in the logcat when calling voicemail.
  
Expected: 
The default voicemail number is shown in the logcat to specify what voicemail number is being called.
  
Environmental Variables:
Device: Flame 2.1 Master (319MB)
BuildID: 20140829040202
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: d697d649c765
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
Notes:
  
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/10198/
See attached: Logcat
(Reporter)

Comment 1

4 years ago
This issue also occurs on the Flame v2.1 (512MB) and Open_C v2.1.

Device: Flame Master (319mb)
Build ID: 20140829040202
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: d697d649c765
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Open_C Master
Build ID: 20140829040202
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: d697d649c765
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The default voicemail number is not shown in the logcat when calling voicemail.

-----------------------------------------

Unable to test on the Flame v2.0 or Open_C v2.0 as the logcat functionality is currently broken.

-----------------------------------------

Unable to test on the Flame v1.4 or the Open_C v1.4 as long pressing 1 on the dialer does not call the voicemail as intended.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
I don't think this would be a blocking issue since the user's voicemail is called even though the number is not shown in the logcat.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.1: affected → ---
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
Whiteboard: [2.1-flame-test-run-1] → [2.1-flame-test-run-1][2.1-flame-test-run-2]
Flags: needinfo?(dharris)

Comment 3

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.