Closed Bug 1060699 Opened 6 years ago Closed 6 years ago

[Status Bar] Ambient Indicator handle width should be based on number of unseen notifications

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- fixed

People

(Reporter: rmacdonald, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe] )

Attachments

(1 file)

In the notifications ambient indicator, a subtle highlighted handle area grows in width on the indicator to let the user know the number of unseen notifications. On the patch, however, the width of the highlight seems to be based on the total number of notifications instead of the total number of unseen notifications.

STR
1) Open the utility tray
2) Clear all notifications
3) Close the utility tray
4) Start creating notifications by doing a screen grab (PWR + Volume down)
5) Repeat step 4 until the width of the notification indicator highlighted area reaches full width
6) Open the utility tray fully... the ambient indicator fades away
7) Close the utility tray
8) Do one more screen grab

Actual Behaviour
The width of the highlight in the indicator is full width.

Desired Behaviour
The width of the highlight should be based on the single notification that is unseen... even if other notifications are still in the utility tray.
Alberto did the initial patch. Reassigning.
Assignee: gmarty → alberto.pastor
Blocks: 996044
Attachment #8482211 - Flags: ui-review?(rmacdonald)
Attachment #8482211 - Flags: review?(mhenretty)
Assignee: alberto.pastor → apastor
Attachment #8482211 - Flags: ui-review?(rmacdonald) → ui-review?(epang)
Comment on attachment 8482211 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23568

Helping Rob out with the ui review because of timezones.  Looks great, thanks Alberto! R+
Attachment #8482211 - Flags: ui-review?(epang) → ui-review+
Attachment #8482211 - Flags: review?(mhenretty) → review+
master: https://github.com/mozilla-b2g/gaia/commit/266a6e4cfac3e145ccf03ccc1b930d97ed192ddc
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
[Blocking Requested - why for this release]: Ambient indicator is new feature for this release, and the current behaviour is not the expected. Also, is low risk.
blocking-b2g: --- → 2.1?
Target Milestone: --- → 2.1 S4 (12sep)
Broken feature.
blocking-b2g: 2.1? → 2.1+
Alberto, please request uplift.
Flags: needinfo?(apastor)
Comment on attachment 8482211 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23568

[Approval Request Comment] This patch adapts the notifications bar size to the spec defined by ux.
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: The notifications bar size will be based on number of notifications, no matter if readen or not.
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Low risk, just changing the condition for deciding the bar size.
[String changes made]: -
Attachment #8482211 - Flags: approval-gaia-v2.1?(fabrice)
Flags: needinfo?(apastor)
Attachment #8482211 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
This is verified fixed in 2.1 KK (319mb) (Full Flash)

Ambient indicator slowly grows with number of active notifications.

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

issue is not verified on 2.2 KK (319mb) (Full Flash)

Ambient indicator does not grow after more then one notification, the indicator stays the same after the first notification. 

This issue still reproduces on Flame 2.x. Filed a new bug 1081531

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Whiteboard: [systemsfe] → [systemsfe] [failed-verification]
QA Whiteboard: [failed-verification]
Whiteboard: [systemsfe] [failed-verification] → [systemsfe]
Depends on: 1081531
The notifications counter has been intentionally removed by UX in 2.2 (and pending uplift to 2.1) in Bug 1073480. Not sure what should we do with this bug, but I'm going to close bug 1081531 as invalid. Thanks!
Not adding to the test suite, as is no longer valid (see comment #11)
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.