Broken Links on mozilla archives "http://www-archive.mozilla.org/quality/browser_sc.html"

RESOLVED WORKSFORME

Status

www.mozilla.org
Pages & Content
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Ajith Moni, Unassigned)

Tracking

Production
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1503021] )

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8481771 [details]
StandardsRemovedHTML.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140807212602

Steps to reproduce:

Navigate to : http://www-archive.mozilla.org/quality/browser_sc.html
Under Available Tests section:
There are broken Links for the following values : 

HTML 4.0 Transitional
CSS1
DOM1 (HTML and CORE)
XML
XHTML 1.0 Transitional (HTML)
XHTML 1.0 Transitional (CSS1)



Actual results:

The following page is displayed with the message : 


Whoops! What are you doing here?

Did you make a left at that last URL instead of a right? No problem. Unless you want us to deal you in, here are some tips to get you back on your way:

    If you typed in the address, check your spelling. Could just be a typo.
    If you’ve found an issue with one of our websites, we’d appreciate it if you could report the problem in Bugzilla, our bug tracker. One of our developers will take a look at it as soon as possible.
    If you followed a link, it’s probably broken.
    If you’re not sure what you’re looking for, start at mozilla.org. 




Expected results:

I should have been led to the archive for the respective links 
Example : 
Text : Networking
Link : http://www-archive.mozilla.org/quality/networking/testing/
Component: Untriaged → Pages & Content
Product: Firefox → www.mozilla.org
Version: 32 Branch → Production
Whiteboard: [kb=1503021]
I've done a bit of digging on this. I'm not sure we need to maintain URLs on an archived site like this, but as the reported suggests, these links should be part of the snapshot archive.

Why, for example is this page part of the archive:
http://www-archive.mozilla.org/quality/browser_sc.html

but this page is not:
https://www.mozilla.org/en-US/quality/browser/standards-removed.html

I can't find the relevant SVN or CVS history, but did find this in the Wayback Machine:
https://web.archive.org/web/20050321041619/http://www.mozilla.org/quality/browser/standards-removed.html

The page includes this quote:

> Standards Compliance Tests Removed
> Due to numerous bugs, lack of a maintainer, and duplication of better-maintained
> test suites, the standards compliance tests previously located here have been
> removed. If you wish to access the tests, we have a tar.gz file containing the
> tests that have been removed.

I'm not sure how the archive snapshot ended up a version of browser_sc.html that references the standards-removed.html file, but doesn't actually include that standards-removed.html file.

So, now, to figure out when/where/how this snapshot was made, and what the state of the source was.
Reminding myself to follow up on this one with a NI
Flags: needinfo?(jbertsch)
Closing.  We don't have bandwidth to maintain this archive.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jbertsch)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.