Closed Bug 1060791 Opened 6 years ago Closed 6 years ago

support OpenType cmap subtable format 10

Categories

(Core :: Graphics: Text, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla35

People

(Reporter: jfkthame, Assigned: jfkthame)

References

Details

Attachments

(2 files)

This subtable format is used, for example, by the Apple Symbols font on OS X. Because Gecko doesn't support it, we fail to use the expected font for an example like

  data:text/html,<div style="font-family:apple symbols">&%23x25ce;&%23x1d330;

Here, the first character falls back to a different font (a Hiragino face, in my case, though YMMV), and the second renders a hexbox as there is no other font that supports the Tai Xuan Jing symbols on a default OS X install.
Here's a reftest that fails on current trunk, due to our inability to use the Apple Symbols font.
Attachment #8481790 - Flags: review?(jdaggett)
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
And a patch that adds support for format 10 subtables.
Attachment #8481791 - Flags: review?(jdaggett)
Tryserver run: https://tbpl.mozilla.org/?tree=Try&rev=beb5bb32ac2b.

For an example of a page affected by this, see https://mathiasbynens.be/notes/es6-unicode-regex. This has a number of instances of U+1D306 TETRAGRAM FOR CENTRE, which is only available in Apple Symbols on OS X with just the default platform fonts installed.
Attachment #8481790 - Flags: review?(jdaggett) → review+
Attachment #8481791 - Flags: review?(jdaggett) → review+
https://hg.mozilla.org/mozilla-central/rev/ae076288ac1b
https://hg.mozilla.org/mozilla-central/rev/f67b22d1d322
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Blocks: 1063931
Verified on https://mathiasbynens.be/notes/es6-unicode-regex with Nightly 35.0a1 (2014-09-06) WFM.
Does not work on Aurora 34.0a2 (2014-09-06) as expected, shows hexbox instead.


Thanks a lot for the quick turnaround! I guess this will not be uplifted to Aurora?
Status: RESOLVED → VERIFIED
Duplicate of this bug: 739410
You need to log in before you can comment on or make changes to this bug.