WebIDE menu incorrectly shows name and icon of the current app

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: WebIDE
--
enhancement
RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: Adrian Custer, Unassigned)

Tracking

34 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The WebIDE user interface shows a menu at the top left of the User interface which allows a user to switch between 'projects' or open new applications (though not close for some reason). 

When a user switches to work on an App, that top-left menu (let's call it the "project menu") changes to have the logo and name of the current app. This is cute but semantically WRONG---none of the entries have anything to do with the current app. The project menu is entirely related to WebIDE and its functions.

The project menu should have its own name and, if an icon, the webide icon.

The feedback of the current project, including its name and icon, should be placed away from this project menu.
Severity: normal → enhancement

Comment 1

3 years ago
Can confirm the behavior.

I feel it's semantically okay because it's meant to toggle between recent projects. I liken it to the "accounts" dropdown in Gmail and other Google apps.

There is no "close" option because closing the WebIDE window closes the project.
Yeah, I believe this is just a UX design choice.  The current approach and the suggestion in comment 0 are both possible approaches, but neither one strikes me as obviously better than the other.

The runtime menu on the right makes the same design choice: the button shows the current runtime, and the menu shows all the available runtimes.  It also has some actions to act on the current runtime.

I'll leave this open for now in case others are similarly confused by the current UX.
Blocks: 1088755
We don't plan to alter the WebIDE interface at this stage, since it's planned for removal (bug 1314811).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.