Adjust b2g bandwidth limits for WebRTC

RESOLVED FIXED in Firefox 34

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jesup, Assigned: jesup)

Tracking

unspecified
mozilla34
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.0+, firefox32 wontfix, firefox33 wontfix, firefox34 fixed, b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
[Blocking Requested - why for this release]:

Since the default capture size in b2g is 320x240 (QVGA), compared to desktop default of VGA, the default bandwidth settings for B2G should be modified as well, doubly so now that H.264 uses the qm_select code to reduce encode resolution as needed (down to 1/2 x 1/2 capture), and to reduce framerate.

As these are prefs, they're easily adjustable by device vendors and QC as well in any case.
(Assignee)

Comment 1

4 years ago
Created attachment 8481856 [details] [diff] [review]
change default bandwidth settings for b2g rs=jesup
(Assignee)

Updated

4 years ago
Attachment #8481856 - Flags: review?(jib)
Attachment #8481856 - Flags: review?(jib) → review+
https://hg.mozilla.org/mozilla-central/rev/bec4694a3c6f
Assignee: nobody → rjesup
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Spoke offline with mreavy and these bandwidth limits will help us a lot during start-up on firefox os and these are low risk.
blocking-b2g: 2.0? → 2.0+
Note that due to recent policy changes, all B2G uplifts needs approval now regardless of blocking status. Please request b2g32 approval on this patch when you get a chance. Sorry for the inconvenience.
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → fixed
status-firefox32: --- → wontfix
status-firefox33: --- → wontfix
status-firefox34: --- → fixed
Flags: needinfo?(rjesup)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8481856 [details] [diff] [review]
change default bandwidth settings for b2g rs=jesup

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a

User impact if declined: Poor quality or failed calls when there's low bandwidth available.

Testing completed: on 34/35 for a few weeks.

Risk to taking this patch (and alternatives if risky): none.  Pref change to lower the minimum bandwidth used

String or UUID changes made by this patch: none
Attachment #8481856 - Flags: approval-mozilla-b2g32?
Flags: needinfo?(rjesup)
Attachment #8481856 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+

Updated

4 years ago
See Also: → bug 1125731

Updated

4 years ago
Blocks: 1054172
You need to log in before you can comment on or make changes to this bug.