Closed Bug 106087 Opened 18 years ago Closed 9 years ago

msgmapi.dll, messenger chrome files loaded at browser startup

Categories

(SeaMonkey :: Startup & Profiles, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bugzilla3, Unassigned)

References

Details

(Keywords: perf)

Attachments

(1 file)

On a total 9 sec of cold start time, we spend 0.36 sec for msgmapi.dll, 0.03 sec
for messenger\content\overlays.rdf and 0.061 sec for messenger.jar (see txt or
excel attachment in bug 7251). This is 5% of total time (maybe more, if there is
additional cpu activity because of compiling the data and memory allocations).
Couldn't these files be late loaded (when Messenger starts)?
Blocks: 7251, 71781
re-assigning to Cavin, this may end up being a dup of bug 26455 though.
Assignee: mscott → cavin
Keywords: perf
QA Contact: esther → stephend
Stephen, I don't see how this is related to bug 26445 which is about mail
startup performance. Anyway, there are a few more things I forgot to report:
- mailnews.js is also loaded during browser startup (26 msec). Couldn't we load
it only when prefs ui is loaded?
- msgmapi.dll does exist on Win2K (and it's used during browser startup) but it
doesn't exist on Win98 installation (the installations are identical with full
pop account information). On the latter, FileMon reports a failed (not found) 
attempt to find msgmapi.dll. Also in your attachment I can't locate msgmapi.dll.
Did you use Win98?
Confirming.  Cavin or Chris, do you know of a bug on the browser said about
loading Mail dlls?
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 127403 has been marked as a duplicate of this bug. ***
I know of an old bug about loading mail dll's (yes I know you asked a long time
ago...). Take a look at bug 12896. I also added a comment in the said bug
pointing at this one.
Any possible progress on this one, or should it go into the "WONTFIX" file?
Product: MailNews → Core
Assignee: cavin → nobody
QA Contact: stephend → backend
Product: Core → MailNews Core
msgmapi.dll does not exists on Vista. It does not appear on windows XP.
While TB2 still runs on win95 and win 98, TB3 as different system requirements (http://www.mozillamessaging.com/en-US/thunderbird/3.0b2/releasenotes/#requirements). TB2 being in maintainance mode - resolving this as WONTFIX
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
(In reply to comment #8)
> msgmapi.dll does not exists on Vista. It does not appear on windows XP.
> While TB2 still runs on win95 and win 98, TB3 as different system requirements
> (http://www.mozillamessaging.com/en-US/thunderbird/3.0b2/releasenotes/#requirements).
> TB2 being in maintainance mode - resolving this as WONTFIX

Well actually we used to ship msgmapi.dll, it got replaced by mozMapi32.dll

This is actually a SeaMonkey bug now (TB has now browser, so its definitely invalid for TB), and I can't decide if its something SeaMonkey needs/wants to look at or not - so moving to SeaMonkey and reopening for now.
Status: RESOLVED → REOPENED
Component: Backend → Startup & Profiles
Product: MailNews Core → SeaMonkey
QA Contact: backend → profile-manager
Resolution: WONTFIX → ---
Mark how about we close this as a dup of bug 119590 ?
Status: REOPENED → NEW
The SeaMonkey team has no interest in fixing this - actually, we even check for mail on browser startup by default now.
Status: NEW → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.