Closed Bug 1060959 Opened 6 years ago Closed 6 years ago

comm-central/configure: line 544: test: : integer expression expected

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 35.0

People

(Reporter: philip.chee, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file, 1 obsolete file)

https://bugzilla.mozilla.org/show_bug.cgi?id=1040009#c28

> >+if test "$MOZ_AUTOMATION" -eq 1; then
> This warns if $MOZ_AUTOMATION isn't an integer expression...
Product: Thunderbird → MailNews Core
Attached patch Change the test in configure.in (obsolete) — Splinter Review
This seems to fix it for me.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #8481976 - Flags: feedback?(philip.chee)
Comment on attachment 8481976 [details] [diff] [review]
Change the test in configure.in

f=me thanks.
Attachment #8481976 - Flags: feedback?(philip.chee) → feedback+
Attachment #8481976 - Flags: review?(Pidgeot18)
Comment on attachment 8481976 [details] [diff] [review]
Change the test in configure.in

Review of attachment 8481976 [details] [diff] [review]:
-----------------------------------------------------------------

The entire if statement should be deleted. It was a temporary workaround to avoid having to make too many coordinated checkins. Now that buildbot has been updated, it's not needed.
Attachment #8481976 - Flags: review?(Pidgeot18) → review-
As suggested remove the entire if statement.
Attachment #8481976 - Attachment is obsolete: true
Attachment #8482440 - Flags: review?(Pidgeot18)
Attachment #8482440 - Flags: review?(Pidgeot18) → review+
Comment on attachment 8482440 [details] [diff] [review]
Remove the test [Checked in: Comment 5]

http://hg.mozilla.org/comm-central/rev/5540d3b4eb23
Attachment #8482440 - Attachment description: Remove the test → Remove the test [Checked in: Comment 5]
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 35.0
Comment on attachment 8482440 [details] [diff] [review]
Remove the test [Checked in: Comment 5]

[Approval Request Comment]
Regression caused by (bug #): 1040009
User impact if declined: Warning when building locally
Testing completed (on c-c, etc.): Locally and now on c-c
Risk to taking this patch (and alternatives if risky): none
Attachment #8482440 - Flags: approval-comm-aurora?
(In reply to Joshua Cranmer [:jcranmer] from comment #3)

> The entire if statement should be deleted. It was a temporary workaround to
> avoid having to make too many coordinated checkins. Now that buildbot has
> been updated, it's not needed.

Yes but have the *SeaMonkey* buildbots been updated? Thunderbird uses the Firefox infra but not SeaMonkey
Attachment #8482440 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.