Marlett font face is used incorrectly

RESOLVED WONTFIX

Status

Tech Evangelism Graveyard
English US
--
minor
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: Jaime Rodriguez, Jr., Assigned: Katsuhiko Momoi)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Build ID: 2001-10-20-11-0.9.4
Reproducible: Always

Steps:
1. Launch the browser
2. Enter the http://jazz/users/ptakhar/publish/clubnet/weekly/thisweek1.html

Results: Most of the page is laid out and disaplys correctly, except for the
8th, or 2nd to the last cell.
(Reporter)

Comment 1

17 years ago
This is happening on many internally produced pages ... here's another example.
http://rocknroll/users/kimk/publish/15thedition3.htm

I am having the people who created the pages send me the Fonts they used.

btw - This displays properly in 4x
(Reporter)

Comment 2

17 years ago
here be the fonts used on this page ...
Header Font for edition and dates is Arial Narrow
Title in header is MT Extra

First Column
Bookman Old Style for first article

Tahoma for Services

Second Column
Garamond for first article

Variable Width for 2nd article

Third Column
Arial Narrow for first article

Marlett for events calendar.

Comment 3

17 years ago
When I've seen this on the Netscape internal pages, the font used is Marlett.
font face="Marlett" is what shows up on Page Source.

Perhaps I need to have that font installed?
(Reporter)

Comment 4

17 years ago
Nominating for the next release nsbeta1. This also dogfood, since folks can't read
messages from Les Concierges or ClubNet using Netscape 6.

Should this be an evangelism issue?
Severity: normal → minor
Keywords: nsbeta1, nsdogfood
Using WINNT, IE 6.0 displays the page identically to Netscape 6. (Substituting a
symbol font). I think you need to have the marlet font installed.  

4.x must use a different algorithm for selecting a font when it doesn't exist on
your system.
Keywords: 4xp
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2
Reassigning to evang.
Assignee: attinasi → nitot
Component: Layout → African
Product: Browser → Tech Evangelism
QA Contact: petersen → momoi
Target Milestone: mozilla1.2 → ---
Version: other → unspecified

Comment 7

17 years ago
Changing compoent to Americas instead of Africa :-)
BTW, could not reproduce on Moz 098 on Win2000 and Mac.
Component: African → The Americas

Comment 8

17 years ago
Reassigning for real, now!
Assignee: nitot → momoi
QA Contact: momoi → jonrubin

Comment 9

16 years ago
Perhaps these Netscape-internal bugs should have their own component?
(Assignee)

Comment 10

15 years ago
I agree with Frankie. This bug should have been filed in Netscape-internal 
Bugzilla. I will upload a test case for Marlett font face.

http://jazz/users/ptakhar/publish/clubnet/weekly/thisweek1.html

This original site no longer shows the problem.
The 2nd page cited is still problematical but it is an obsolete
page.

BTW, Marlett font is actually installed on Windows 9x onward in
your system but the "invisible" flag is set so that you cannot
see the font name in Explorer or Fonts Control Panel utility. 

So the original problem has to do with some Mozilla build
honoring the font face attribute. Then we stopped honoring it
for a while. Now the current trunk build supports font face --
so you will see the problem. See this page for Marlett font 
info:

http://www.microsoft.com/typography/faq/faq1c.htm

See the test case attached below. 



Summary: Text Characters show up as glyphs → Marlett font face is used incorrectly
(Assignee)

Comment 11

15 years ago
Created attachment 118743 [details]
Test case for Marlett font face attribute.
(Assignee)

Comment 12

15 years ago
Created attachment 118745 [details]
The prior test case had badly worded explanation. Replace it with this one.
Attachment #118743 - Attachment is obsolete: true
(Assignee)

Comment 13

15 years ago
The old page is not worth fixing.
Resolving it as Wontfix. May file a bug Netscape-internally.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 14

15 years ago
Moving to English-US.
Component: The Americas → English US
QA Contact: jonrubin → english-us
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.