[Settings] Icon for the EU roaming notification

RESOLVED FIXED in Firefox OS v2.1

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: arthurcc, Assigned: arthurcc)

Tracking

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(4 attachments)

Created attachment 8482047 [details]
eu_roaming.png

We need an icon for the EU roaming notification as the attachment shows.
Hi Helen, the original bug was resolved as we had to land the patch before the v2.1 branching. Let's use this one for tracking the icon, thanks.
Flags: needinfo?(hhuang)
Created attachment 8482209 [details]
Icons.zip

Hi Arthur, thanks for letting me know.
I've updated the icons, please see the attachment.
Flags: needinfo?(hhuang)
Thanks! And I just realized that recently we switched to use gaia-icons, could you provide the icon in svg format?
Flags: needinfo?(hhuang)
You could refer to what we have in gaia-icons here[1].

[1]: https://github.com/gaia-components/gaia-icons/tree/master/images
Created attachment 8482474 [details]
eu_roaming.svg

Sure! SVG file updated.
Flags: needinfo?(hhuang)
hmm, notifications don't take gaia icons... use png files instead...
Created attachment 8482523 [details]
link to https://github.com/mozilla-b2g/gaia/pull/23609

Alive, would you mind review this simple patch? Thanks.
Attachment #8482523 - Flags: review?(alive)
Thanks, Alive!

master: 6c32f751b299e6b9e279bb78ede85104ebaf7d14
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8482523 [details]
link to https://github.com/mozilla-b2g/gaia/pull/23609

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1032631
[User impact] if declined: Low. Users will not see the icon for EU roaming notifications.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8482523 - Flags: approval-gaia-v2.1?
Attachment #8482523 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/496fe6bf1653112069fdd4e0afb244087b658a7f
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed
Target Milestone: --- → 2.1 S4 (12sep)
You need to log in before you can comment on or make changes to this bug.