MailNews doesn't parse ezmlm MIME digests correctly

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: oliver, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101201

This may be a bug in Mozilla or it might be a bug in ezmlm (EZ Mailing List
Manager) I'm reporting it both parties.

Moz MailNews doesn't seem to parse ezmlm MIME digests correctly.  This can be
see if you subscribe to bugtraq-digest@securityfocus.com or
squid-users-digest@squid-cache.org.  

What usually happens is that the 'contents' text/plain attachment is shown in
the mail view pane along with the first message.  All other messages are not
shown in the view pane or in the attachment list.  

Outlook Express on the other hand shows all the messages attached in its
attachment list.  I can only assume that Moz isn't parsing the attachments
correctly.


Reproducible: Always
Steps to Reproduce:
1. Subscribe to bugtraq-digest@securityfocus.com
2. Wait for a digest to arrive.
3. Observe flaw.

Actual Results:  Mail isn't shown correctly with all the attachements or
messages in the view pane.

Expected Results:  You should beable to read all the attachments either by
opening the attachments or in the view pane directly.  This works fine with
mailman based digests.
(Assignee)

Comment 1

17 years ago
Reporter, can you attach a copy of the email messsage that show the problem to
this bug report. For that, select it and save it as file, then attach the file
to the bug report. Thanks

It's possible that I have already fixed this problem couple weeks ago.
(Reporter)

Comment 2

17 years ago
Created attachment 54584 [details]
Digest of squid-users (as requested)
(Assignee)

Updated

17 years ago
Attachment #54584 - Attachment mime type: application/octet-stream → text/plain

Comment 3

17 years ago
mozilla only shows one attachment. Outlook Express shows many.
20020116
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
WORKSFORME with Jan 28 2002 trunk
(Assignee)

Comment 5

17 years ago
Works for me too.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.