Closed Bug 1061090 Opened 5 years ago Closed 2 years ago

[MTP] Default transfer protocol should be MTP

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.1 affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- affected

People

(Reporter: ashiue, Unassigned)

References

Details

(Whiteboard: [2.1-flame-test-run-2] )

Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1

STR:
1. Flash new version on device
2. Go to Settings -> Storage section
3. Tap on "USB storage"

Expect result:
Default transfer protocol should be MTP

Actual result:
Default transfer protocol is UMS
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Storage]
It's an intended behavior for 2.1 decided in bug 964601 comment 8 .

tech(alphan) feedback
"if there is UMS support, it is good to set UMS as default.
UMS is more stable and faster than MTP.
As Dave said, UMS can work well on anywhere but MTP can't."

UX (jenny) feedback:
"If there's technical concerns, I'm ok with using UMS as default. However, when MTP is stabilized in the future, we should switch back to MTP."
Depends on: 964601
let's use this as followup if one day we like to switch back to MTP
Sounds reasonable to me. I'd like to see MTP get a lot more use/testing/stabilization before we decide to make it be the default.
blocking-b2g: 2.1? → backlog
QA Whiteboard: [COM=Storage] → [COM=Storage][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.1-flame-test-run-2]
QA Whiteboard: [COM=Storage][QAnalyst-Triage?] → [COM=Storage][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Storage][QAnalyst-Triage+] → [COM=Storage][QAnalyst-Triage+][lead-review+]
QA Whiteboard: [COM=Storage][QAnalyst-Triage+][lead-review+] → [COM=MTP/UMS][QAnalyst-Triage+][lead-review+]
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.