Closed Bug 1061171 Opened 6 years ago Closed 6 years ago

video picture black on OSX

Categories

(Core :: Audio/Video, defect)

34 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1055694

People

(Reporter: alberts, Unassigned)

References

()

Details

For the last couple of days, since H.264 was enabled on Nightly videos are displayed black for me. The audio is working fine, though. This happens e.g. on the Firefox youtube channel.
It happens on my main profile as well as in a new one.

While writing this I quickly wanted to check Vimeo where the following video came up first & directly crashed my fox: http://vimeo.com/originals/lumia/101557016
Blocks: 799318
Component: General → Video/Audio
Product: Firefox → Core
Unable to reproduce, 34.0a1 (2014-08-31), OS X 10.9.4
(In reply to Paul Silaghi, QA [:pauly] from comment #1)
> Unable to reproduce, 34.0a1 (2014-08-31), OS X 10.9.4

OK, that's odd. I just downloaded a fresh copy* and created a brand new profile with still the same result. No picture on youtube. Anything I can change/check on my Mac which might be different to your prefs?

*http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-34.0a1.en-US.mac.dmg
It could be related to your graphic card.
Tried again on OS X 10.8.5 and everything's ok too.
It's an end 2009 MacBook with - Graphics  NVIDIA GeForce 9400M 256 MB; can't change it for testing, though ;)
What MacOS X version? If you're running yosemite this is probably bug 1054789. If not, it's something new.
Flags: needinfo?(albert)
Sorry forgot to add. I am on 10.9.4; as I also have a lot of crashes, could it be related to bug 1055694?
Flags: needinfo?(albert)
I can confirm - on fx 35.0a1, os x 10.9.4, mid 2009 mac book pro with NVIDIA GeForce 9400M 256 MB I get:
http://vimeo.com/originals/lumia/101557016 - black screen and crashes
https://www.youtube.com/embed/Xm5i5kbIXzc - black screen and crashes
https://www.youtube.com/user/firefoxchannel - black screen
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see this too: No/black video, audio is ok on any of the usual video platforms.

Facts:
* OS X 10.9.4
* "Early 2009" 17" MBP
* Graphics NVIDIA GeForce 9600M GT 512 MB
35.0a1, build 20140904030202 all issues gone, related to/dupe of 1055694?
As Stefan says, video plays after: 

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140904030202 CSet: 776fa9cf70cd

But I'm less convinced that all problems are gone.  I'll describe my experience -- which I don't think I want to try to duplicate.

I watched this video:

https://www.youtube.com/watch?v=UowkIRSDHfs

I set it to 720 HD, got to full screen, answered Allow to the "Allow/Deny full screen" prompt.  I did this a few times, each time trying to "cancel" YouTube's "Next video in x seconds" prompt at the lower right of the screen (I never was successful at that).  Anyway, after a few efforts going in and out of full screen, I got the beach ball.  I could cmd+tab to see my opens apps, but couldn't switch to them.  Seems to me Finder died, and I never was able to relaunch Finder, so I had to 4-second the power button.

I haven't seen my machine die like that for years, so I'm willing to believe that there's some refinement yet to do.

Other than that, video's working pretty well!
(In reply to Frank Burleigh from comment #10)
 
> I haven't seen my machine die like that for years, so I'm willing to believe
> that there's some refinement yet to do.

Maybe that needs to be raised a new bug?

> 
> Other than that, video's working pretty well!

(In reply to Stefan Plewako [:stef] from comment #9)
> 35.0a1, build 20140904030202 all issues gone, related to/dupe of 1055694?

I suspected it as well. The videos I mentioned above are all working for me know, so I am closing this task as a duplicate.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1055694
You need to log in before you can comment on or make changes to this bug.