Closed Bug 1061174 Opened 6 years ago Closed 5 years ago

Intermittent test_udpsocket.html | timeout for sending big array

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox37 --- wontfix
firefox38 --- fixed
firefox39 --- fixed
firefox-esr31 --- unaffected
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: cbook, Assigned: schien)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

b2g_emulator_vm b2g-inbound debug test mochitest-debug-10 on 2014-08-31 18:03:25 PDT for push 4fc76317f526

slave: tst-linux64-spot-028

https://tbpl.mozilla.org/php/getParsedLog.php?id=47142580&tree=B2g-Inbound

49 INFO TEST-UNEXPECTED-FAIL | /tests/dom/network/tests/test_udpsocket.html | timeout for sending big array
Do you have some cycles to look into this? :)
Flags: needinfo?(schien)
Nevermind, whatever made this spike aross trees was too frequent to leave the test enabled. Disabled on B2G debug.
https://hg.mozilla.org/integration/b2g-inbound/rev/b79f77aad73a
Flags: needinfo?(schien)
Whiteboard: [test disabled on B2G debug][leave open]
Sorry I let this bug slip through my radar, will take a look at it.
(keep the ni? as a remainder)
Assignee: nobody → schien
Found UDPSocket will only be closed until window destroy and doesn't get CC'ed. The root cause is that nsUDPSocket/UDPSocketChild hold a strong reference of UDPSocket object as the listener callback. By using a proxy object and weak reference, UDPSocket can now be CC'ed when there is no javascript variable holds it.

The try result of test_udpsocket.html looks much more stable across all platform now.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=430b12821d35
Attachment #8577176 - Flags: review?(khuey)
Remove some unnecessary timeout and re-enable test_udpsocket.html on all platform.
Attachment #8577177 - Flags: review?(khuey)
Let's see how it work on inbound and central.

full run result on try: (oranges are non-related test failure)
https://treeherder.mozilla.org/#/jobs?repo=try&revision=303fb1579570
Keywords: checkin-needed
Whiteboard: [test disabled on B2G debug][leave open] → [leave open]
Is this fixed now? Also, please nominate for b2g37 approval if it is :)
Flags: needinfo?(schien)
Comment on attachment 8577176 [details] [diff] [review]
Part 1, fix-udpsocket-leak.patch

Approval Request Comment
[Feature/regressing bug #]: 745283
[User impact if declined]: socket will not be closed until app/page close.
[Describe test coverage new/current, TreeHerder]: re-enable mochitest case on all platform.
[Risks and why]: low, small and simple patch.
[String/UUID change made/needed]: N/A

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 745283
User impact if declined: socket will not be closed until app/page close.
Testing completed: Y
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: N/A
Flags: needinfo?(schien)
Attachment #8577176 - Flags: approval-mozilla-b2g37?
Attachment #8577176 - Flags: approval-mozilla-aurora?
Comment on attachment 8577177 [details] [diff] [review]
Part 2, remove-flaky-timer.patch

Approval Request Comment
[Feature/regressing bug #]: 745283
[User impact if declined]: N/A, just a fix for intermittent test failure
[Describe test coverage new/current, TreeHerder]: re-enable test case on all platform
[Risks and why]: low, patch for auto test
[String/UUID change made/needed]: N/A

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 745283
User impact if declined: N/A, just a fix for intermittent test failure
Testing completed: Y
Risk to taking this patch (and alternatives if risky):  low
String or UUID changes made by this patch: N/A
Attachment #8577177 - Flags: approval-mozilla-b2g37?
Attachment #8577177 - Flags: approval-mozilla-aurora?
Attachment #8577176 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8577177 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [leave open]
Target Milestone: --- → mozilla39
Attachment #8577176 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8577177 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.