Intermittent 863929.html | application crashed [@ mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track*, unsigned int, long long, l

RESOLVED DUPLICATE of bug 1059101

Status

()

Core
General
RESOLVED DUPLICATE of bug 1059101
4 years ago
4 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test crashtest on 2014-09-01 03:46:57 PDT for push bdb0a8c2902d

slave: t-snow-r4-0162

https://tbpl.mozilla.org/php/getParsedLog.php?id=47164618&tree=Mozilla-Inbound

3:52:00  WARNING -  PROCESS-CRASH | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/dom/media/tests/crashtests/863929.html | application crashed [@ mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track*, unsigned int, long long, long long, bool*)]
03:52:00     INFO -  Crash dump filename: /var/folders/7M/7MbvOWB9H3WV+DYkjCmP1++++-k/-Tmp-/tmpK9pv6m.mozrunner/minidumps/4B18E7F6-32FB-48EE-8F3D-AD865B49E1A3.dmp
03:52:00     INFO -  Operating system: Mac OS X
03:52:00     INFO -                    10.6.8 10K549
03:52:00     INFO -  CPU: amd64
03:52:00     INFO -       family 6 model 23 stepping 10
03:52:00     INFO -       2 CPUs
03:52:00     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
03:52:00     INFO -  Crash address: 0x0
03:52:00     INFO -  Thread 46 (crashed)
03:52:00     INFO -   0  XUL!mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track*, unsigned int, long long, long long, bool*) [nsTArray.h:bdb0a8c2902d : 866 + 0x0]
03:52:00     INFO -      rbx = 0x00007fff7075d2f8   r12 = 0x0000000000003a66
03:52:00     INFO -      r13 = 0x0000000000096600   r14 = 0x000000011dfcb080
03:52:00     INFO -      r15 = 0x00000000000f4240   rip = 0x00000001037d6ac8
03:52:00     INFO -      rsp = 0x0000000128bb69a0   rbp = 0x0000000128bb6a80
03:52:00     INFO -      Found by: given as instruction pointer in context
03:52:00     INFO -   1  XUL!mozilla::TrackUnionStream::ProcessInput(long long, long long, unsigned int) [TrackUnionStream.h:bdb0a8c2902d : 77 + 0x1f]
03:52:00     INFO -      rbx = 0x000000011c58a3a0   r12 = 0x0000000000000000
03:52:00     INFO -      r13 = 0x0000000000000000   r14 = 0x00000001263904e0
03:52:00     INFO -      r15 = 0x0000000000000000   rip = 0x00000001037d6047
03:52:00     INFO -      rsp = 0x0000000128bb6a90   rbp = 0x0000000128bb6b60
03:52:00     INFO -      Found by: call frame info
03:52:00     INFO -   2  XUL!mozilla::MediaStreamGraphImpl::Process(long long, long long) [MediaStreamGraph.cpp:bdb0a8c2902d : 1306 + 0x1e]
03:52:00     INFO -      rbx = 0x0000000000096780   r12 = 0x0000000000096600
03:52:00     INFO -      r13 = 0x000000011ddda440   r14 = 0x000000011dfcb080
03:52:00     INFO -      r15 = 0x000000011dfcb080   rip = 0x00000001037c0da3
03:52:00     INFO -      rsp = 0x0000000128bb6b70   rbp = 0x0000000128bb6bd0
03:52:00     INFO -      Found by: call frame info
03:52:00     INFO -   3  XUL!mozilla::MediaStreamGraphImpl::OneIteration(long long, long long, long long, long long) [MediaStreamGraph.cpp:bdb0a8c2902d : 1387 + 0xe]
03:52:00     INFO -      rbx = 0x000000011ddda440   r12 = 0x000000011ddda440
03:52:00     INFO -      r13 = 0x0000000106ea80d8   r14 = 0x0000000000096780
03:52:00     INFO -      r15 = 0x000000000000ac44   rip = 0x00000001037c11c6
03:52:00     INFO -      rsp = 0x0000000128bb6be0   rbp = 0x0000000128bb6c60
03:52:00     INFO -      Found by: call frame info
03:52:00     INFO -   4  XUL!mozilla::ThreadedDriver::RunThread() [GraphDriver.cpp:bdb0a8c2902d : 257 + 0x4]
03:52:00     INFO -      rbx = 0x0000000127c03cf0   r12 = 0x000000011ddda440
03:52:00     INFO -      r13 = 0x0000000106ea80d8   r14 = 0x000000000009622a
03:52:00     INFO -      r15 = 0x000000000000ac44   rip = 0x000000010378a74f
03:52:00     INFO -      rsp = 0x0000000128bb6c70   rbp = 0x0000000128bb6cb0
03:52:00     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I don't think we need 7 dupes for the same root bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1059101
You need to log in before you can comment on or make changes to this bug.