Docs: Link to Swagger API docs from treeherder readthedocs and the wiki page

RESOLVED DUPLICATE of bug 1175935

Status

Tree Management
Treeherder: Docs & Development
P3
normal
RESOLVED DUPLICATE of bug 1175935
3 years ago
2 years ago

People

(Reporter: emorley, Unassigned, Mentored)

Tracking

Details

(Whiteboard: [good first bug][lang=html])

User Story

Thank you for helping out with Treeherder!

You can find us on IRC at irc://irc.mozilla.org/treeherder

Here's some links to help get you started.

Project page:
https://wiki.mozilla.org/Auto-tools/Projects/Treeherder

Interacting with us, repo locations and links to set up a development version of the software:
https://wiki.mozilla.org/Auto-tools/Projects/Treeherder#Contributing
https://wiki.mozilla.org/Auto-tools/Projects/Treeherder#Source_and_Docs

A-Team general reference, coding style guides:
http://ateam-bootcamp.readthedocs.org
(Reporter)

Description

3 years ago
Currently https://treeherder.mozilla.org/docs/ isn't mentioned at all on:
https://treeherder-service.readthedocs.org/en/latest/index.html

We should add a mention to it.
(Reporter)

Updated

3 years ago
Priority: P3 → P2
(Reporter)

Comment 1

3 years ago
Swagger was disabled on prod due to load concerns, so the wiki (and as such the addition requested in this bug should) point to http://treeherder-dev.allizom.org/docs/
Blocks: 1072681
(Reporter)

Updated

3 years ago
Assignee: nobody → emorley
Status: NEW → ASSIGNED
(Reporter)

Updated

3 years ago
No longer blocks: 1072681
Component: Treeherder → Treeherder: Docs & Development
(Reporter)

Updated

3 years ago
Assignee: emorley → nobody
Status: ASSIGNED → NEW
Priority: P2 → P3
(Reporter)

Updated

3 years ago
Priority: P3 → P4
Mentor: emorley@mozilla.com
User Story: (updated)
Whiteboard: [good first bug]
(Reporter)

Updated

3 years ago
Whiteboard: [good first bug] → [good first bug][lang=html]
User Story: (updated)

Comment 2

2 years ago
Sir,
I have some knowledge of HTML and CSS (still a first-year student of Computer Science) and I would like to work on this bug if it is still open, however i'm not really sure what is to be done and where. I've not contributed much to open-source projects before so a little guidance would be appreciated.
Thanks!
Hi Aditya! I'm just checked with Ed in channel to see if the bug is still valid. We did a bunch of large repo changes recently. If this bug isn't, there will be others you can work on for sure :)
(Reporter)

Comment 4

2 years ago
Bug 1167349 needs to be fixed first.
Depends on: 1167349
(Reporter)

Updated

2 years ago
Summary: Docs: Link to Swagger API docs from treeherder-service readthedocs → Docs: Link to Swagger API docs from treeherder readthedocs and the wiki page
Aditya, if there's another bugsahoy good first bug you'd like to try in the interim, before bug 1167349 is fixed, let us know in that bug and we can assign you. Thanks!
(Reporter)

Updated

2 years ago
Priority: P4 → P3
I'm fixing this as part of bug 1175935
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175935
You need to log in before you can comment on or make changes to this bug.