Error message for unverified account shows up when offline

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
FindMyDevice
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: ggp, Assigned: ggp)

Tracking

unspecified
2.1 S4 (12sep)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
STR:
1- Make sure the device is offline
2- Open the Settings app and navigate to Find My Device
3- Observe the message that reads "Click the verification link in your email to confirm your account"

Expected: the message shouldn't appear.

Note: this bug manifests itself regardless of whether you're logged out, or logged in with a verified account.
(Assignee)

Comment 1

4 years ago
Created attachment 8482369 [details] [diff] [review]
GitHub pull request
(Assignee)

Comment 2

4 years ago
Comment on attachment 8482369 [details] [diff] [review]
GitHub pull request

This PR hides the error message by default, and adds a couple of tests. Also, I've moved the code that was previously in suiteSetup/suiteTeardown to setup/teardown, as that was causing dependencies between tests.
Attachment #8482369 - Flags: review?(arthur.chen)
(Assignee)

Updated

4 years ago
Attachment #8482369 - Attachment is patch: true
Attachment #8482369 - Attachment mime type: text/x-github-pull-request → text/plain

Comment 3

4 years ago
[Blocking Requested - why for this release]:this is a bad user experience.
blocking-b2g: --- → 2.1?
Comment on attachment 8482369 [details] [diff] [review]
GitHub pull request

Looks good to me, thanks!
Attachment #8482369 - Flags: review?(arthur.chen) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Have you confirmed that the Linter failures in the Gaia-Try run aren't yours? They don't look related, but I also don't see anything like those on b2g-inbound from a busted landing.
Keywords: checkin-needed
(Assignee)

Comment 6

4 years ago
I rebased an re-ran this through Gaia-Try, the linter tests are green again.
https://tbpl.mozilla.org/?rev=219021952f128b3a2fac2c2c65fdd4533262cb9a&tree=Gaia-Try
Keywords: checkin-needed
Thanks :)

Master: https://github.com/mozilla-b2g/gaia/commit/19c62641af84b275ed92a2ab867df7ea988c4186
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Is this a regression in 2.1?, which is the only reason I would consider blocking for 2.1+

You are free to seek approval for 2.1 on this to consider it for landing either ways(blocking or non-blocking).  Depending on the risk/reward, we can consider uplift here. So could you please do that ?
Flags: needinfo?(ggoncalves)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8482369 [details] [diff] [review]
GitHub pull request

This is a bug that went unnoticed from 2.0, so it's not a regression. I'll request approval then, as this is a very low-risk fix for an unlikely bug.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1037232
[User impact] if declined: An error string will erroneously appear when offline
[Testing completed]: Manual and Gaia unit testing
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]: None
Attachment #8482369 - Flags: approval-gaia-v2.1?(bbajaj)
Flags: needinfo?(ggoncalves)

Updated

4 years ago
Attachment #8482369 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Triage reviewed, blocking- per comment #8 and #9.
blocking-b2g: 2.1? → -

Comment 12

3 years ago
This issue has been verified successfully on Flame2.1&2.2, it will prompt "This device is currently offline.Connect to a network and try again" when tapping the "Create account or sign in".
Reproducing rate: 0/5
See attachment: Verify_Flame_FMD.mp4

Flame2.1 build version:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0

Flame2.2 build version:
Gaia-Rev        984e6d79aa799d2695f9ca132dfdc1665a56c019
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a9fc46355661
Build-ID        20141204040202
Version         37.0a1
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Comment 13

3 years ago
Created attachment 8532408 [details]
Verify_Flame_FMD.MP4
You need to log in before you can comment on or make changes to this bug.