Similar Jobs left/right content panes obscure each other

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: jfrench, Assigned: wlach)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Perhaps spawned from the work in bug 1042599, at pretty reasonable browser widths (eg. 1000 wide), the Similar Jobs right-panel, obscures content in the Similar Jobs left-panel.

To reproduce
o open treeherder production
o click on any job
o resize your browser down to about 1000px wide

Expected behavior
The left-hand and right-hand panels remain separate and I would assume overflow hidden.

Observed behavior
The right-hand 'Similar Jobs' pane overlays and obscures content in the left-hand 'Similar Jobs' pane. I will attach a screen grab.
(Reporter)

Comment 1

3 years ago
Created attachment 8482398 [details]
similarJobsObscuresAt1000pxWide

This is the observed behavior.
Yeah, this is a big problem. We need to fix it IMO. :)
Created attachment 8483105 [details] [review]
Fix/improve display of similar jobs
Assignee: nobody → wlachance
Attachment #8483105 - Flags: review?(jeads)
Attachment #8483105 - Flags: feedback?(emorley)
Created attachment 8483106 [details]
similar-jobs-new-layout.png

Here's a screenshot of what the similar jobs view now looks like with the patch applied. Much better, and works on smaller screens. Note that log lines now wrap in the right panel (we turned that off before), but I think that's probably the behavior we want.

Updated

3 years ago
Status: NEW → ASSIGNED

Comment 5

3 years ago
Comment on attachment 8483105 [details] [review]
Fix/improve display of similar jobs

Looks much better thank you :-)
Attachment #8483105 - Flags: feedback?(emorley) → feedback+

Updated

3 years ago
Blocks: 1043474
Comment on attachment 8483105 [details] [review]
Fix/improve display of similar jobs

Moar flex!
Attachment #8483105 - Flags: review?(jeads) → review+

Comment 7

3 years ago
https://github.com/mozilla/treeherder-ui/commit/adbe2b5f11af63b86f80dd1381da02287bae879a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 8

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/dae247d1907a8fcdd53447922a60f1ad1fd67b82
Bug 1061312 - Fix/improve display of similar jobs

In particular, overflow is now handled way better than it was before on small
screens.
You need to log in before you can comment on or make changes to this bug.