Opening link on frame page to frame page in a new tab and Mozilla crashes

VERIFIED FIXED

Status

SeaMonkey
Tabbed Browser
--
critical
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: TGOS, Assigned: David Hyatt)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I'm using Mozilla Build ID 2001101117

Okay, that's now a bit more complicated to reproduce:

1) Go to http://mpegplus.de/eng/
That's a page using frame.

2) Choose "What is MpegPlus" from the left navigation menu, to replace the
current right frame.

3) On the page that shows up to the right is a link to "MpegPlus.net".
Another page using frames, BTW.

4) Right-click on that link and choose "Open in a New Tab".

5) Mozilla will try to load this other page in a new tab and that's the last
thing it tries to do.

Dr. Watson explains the crash as follows:
"GKGFXWIN.DLL tries an invalid memory access"

However, in advanced mode it says:
"GKGFXWIN.DLL tries to use a null pointer"

Dr. Watson also creates something, I think one could call it a stack trace and
it runs a disassembler over plenty of source code lines... however, I'm not
quite sure if that's any help for you, if you see which assembler line was
trying to use this null pointer.
(Reporter)

Comment 1

16 years ago
Created attachment 54572 [details]
Dr. Watson stack trace and dissambler output
wfm with win2k build 20011022..

Reporter: 
Please use a talkback enabled build. After talkback submitted the crash run 
"Install-dir\mozilla\components\talkback.exe" and poste the Talkback ID here.

Keywords: crash
tabbed browser
Assignee: asa → hyatt
Component: Browser-General → Tabbed Browser
QA Contact: doronr → blakeross
(Reporter)

Comment 4

16 years ago
I replaced my old installation with the current nightly build and it does at
least not crash, so maybe the problem was already solved somehow. But since it
also does not open the page in a new tab... nor any other link I choose to open
in a new tab, I can't check for this problem as long as this other bug isn't
fixed and tab browsing works again.
Tabbed browsing has seen changes since this was reported.
Try to reproduce this again with the latest nightly.
(Reporter)

Comment 6

16 years ago
Okay, this issue seems to be resolved (at least let's hope it is). I can't
reproduce this bug anymore using nightly build ID 2001102403. At least at the
moment the second page opens without problem in a new tab.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: blakeross → sairuh
no longer a problem when using the original test case. also tried
http://www.wired.com/ then selecting Open in New Tab when over the "Wired News"
graphic in the upper-left: other framed page loaded fine, no crash.

vrfy'd fixed with 2001.11.28.0x-comm bits on linux rh7.2, mac 10.1.1 and winnt.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.