Subscribe-to-newsgroups broken if double-clicked

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: jim.avera, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20011001
BuildID:    2001100108

In the news browser, double-clicking "Subscribe to newsgroups"
brings up a Subscribe dialog box which is unable to
contact the news server -- the Refresh button does nothing,
and if the account was newly created, the server is not
automatically contacted to retrieve the initial newsgroup list.

Single-clicking works, however.

So there must be a race condition where two rapid clicks hits a bug.

Reproducible: Always
Steps to Reproduce:
1.Tasks->Mail & Newsgroups
2.(If no news accounts exist, use Create Account)
3.Click on a valid new server ("account") in the left column.
4.Rapidly double-click "Subscribe to Newsgroups"



Actual Results:  
good: One Subscribe dialog popped up.
bad: If the account was newly created, the news server was not
      contacted to get the initial newsgroup list.
bad: Clicking on Refresh did nothing.

Expected Results:  If the account was newly created, then the server should
be contacted automatically to get the initial newsgroup list
when the Subscribe dialog is first entered.

Thereafter, Refresh should contact the server to update
the newsgroup list.

(this is how it works if you single-click on "Subscribe to newsgroups")

I used tcpdump to confirm that mozilla did not contact the
news server when the bug happened.

P.S. Initially I though Mozilla news was just completely
broken, because I was double-clicking by habbit from using
another news reader.  But once in a while it seemed to work,
and eventually I realized that double-clicking was causing
the incorrect behavior.

Comment 1

17 years ago
->MailNews Product
Assignee: asa → sspitzer
Component: Browser-General → Subscribe
Product: Browser → MailNews
QA Contact: doronr → stephend
I can't so far reproduce this...Jim, do you see this everytime?
(Reporter)

Comment 3

17 years ago
Every time.  Just tried it on 2001111109.  Got 
  run-mozilla.sh: line 72:  <PID> Segmentation fault

Just before mozilla crashes an empty window pops up with
"Subscribe" in the window-manager title bar.

I see this when double-clicking on "Subscribe to Newsgroups"
in the main (right hand) part of the Mail/News window.
I don't see this on build 2001-11-09-21 running RedHat 7.2 with Ximian Gnome
(all updates to Gnome).  Can you get a talkback-enabled tar.gz and when it
crashes, send the incident and report back in this bug the ID #?  Thanks!
(Reporter)

Comment 5

17 years ago
I can't (or don't know how to) get talkback to do anything...

So I used gdb to attach to a running mozilla-bin process
before provoking the segfault, and got stack traces of all the threads.
It looks like the segfault happens in NSGetModule, which seems to
call itself a large number of times (maybe there are intermediate
functions which are inlined or otherwise not visible to gdb).

The traces are long, so I'll attach them in a separate file.
(Reporter)

Comment 6

17 years ago
Created attachment 57670 [details]
gdb stack traces after segfault

Here are the stack traces taken with gdb.
I first ran mozilla -news normally.  Then in another xterm,
used ps to find the pid of the first mozilla-bin process
(which always seems to be the pid which gets the segfault).
Then ran  gdb .../mozilla-bin pid
Then double-clicked on the Subscribe To Newsgroups link,
 and after gdb stopped with the segv message, I did 
threads apply all bt   to get traces of all threads.

See thread 1024
Hrm, you're crashing in widget code.  Can you provide details of your machine
config?  Thanks!  Also, any luck with a talkback build yet?
(Reporter)

Comment 8

17 years ago
I'm running SuSE 7.2 with ximian gnome 1.4 installed on top.

But the double-click problem seems to have 
gone away in recent builds (e.g. 2001112108).
Sigh.  

So I don't mind if you resolve this as WFM.
Okay, thanks.  Will re-open if we see this again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.